Seahub_setting.py

Hi!
I recently made a new install of SeaFile in Windows. Everything is working fine nor, we cannot manage the seahub_setting.py files because they’re like “encrypted”?

Attach of one of them:

Please help us!
Thanks in advance

Just try to add new options at the end of the file and restart Seafile.

Did it and seafile server didn’t start. It’s so weird because I’ve ever seen a settings.py like this.

Hm the Secret Key is too Long. You might want to generate a new one. Under Linux there is a Script for that available. What does the log files say?

Thanks for the help. I’ve made a lot of advance, but now, client-side I get this error when they try to move anything to Seadrive “drive”.
Any idea?

[08/24/18 12:22:48] http-tx-mgr.c(1262): Bad response code for GET http://seafile.dotgainen.es/seafhttp/protocol-version: 404.
[08/24/18 12:23:09] http-tx-mgr.c(674): libcurl failed to GET http://seafile.dotgainen.es:8082/protocol-version: Couldn't connect to server.
[08/24/18 12:23:10] http-tx-mgr.c(1262): Bad response code for GET http://seafile.dotgainen.es/seafhttp/protocol-version: 404.
[08/24/18 12:23:31] http-tx-mgr.c(674): libcurl failed to GET http://seafile.dotgainen.es:8082/protocol-version: Couldn't connect to server.
[08/24/18 12:23:32] http-tx-mgr.c(1262): Bad response code for GET http://seafile.dotgainen.es/seafhttp/protocol-version: 404.
[08/24/18 12:23:46] http-tx-mgr.c(2286): Bad response code for GET http://seafile.dotgainen.es/api2/repos/: 401.
[08/24/18 12:23:53] http-tx-mgr.c(674): libcurl failed to GET http://seafile.dotgainen.es:8082/protocol-version: Couldn't connect to server.
[08/24/18 12:23:54] http-tx-mgr.c(1262): Bad response code for GET http://seafile.dotgainen.es/seafhttp/protocol-version: 404.
[08/24/18 12:24:15] http-tx-mgr.c(674): libcurl failed to GET http://seafile.dotgainen.es:8082/protocol-version: Couldn't connect to server.
[08/24/18 12:24:16] http-tx-mgr.c(1262): Bad response code for GET http://seafile.dotgainen.es/seafhttp/protocol-version: 404.

The server is up, and from the web based there’s no trouble.

Ok and does the normal client work? Anything in the server logs?

And which server address did you use? The client shows port 8082 and without in combination, that is not normal.

My server address is http://seafile.dotgainen.es
Whay do you mean with combination? I’m so noob at Seafile, and wanted to make it in Win, but as I see It’s harder xD

Here you can see that the client tries to use it with port 80 (no : after your server address) and 8082. That should not happen.

Most likely wrong FILE_SERVER_ROOT

Or if no proxy is being used port 8082 is blocked by a firewall.

Thanks. There’s no proxy, so I’ll check FILE_SERVER_ROOT, even do I have to change in settings the 8082 to 80?

Kind regards

I think FILE_SERVER_ROOT is wrong too. Just use the correct setting and restart seafile and try it again. I dont know what server address you used in your client, but it should be without that 8082 port.

When you do not use a proxy make sure port 8082 is reachable for the clients (e.g. open it in the firewall).

The server is on the DMZ, so, there’s no blocked ports :S

Maybe blocked by the Windows firewall? At least it currently is not reachable http://seafile.dotgainen.es:8082/

Is there some other service running on 8082?

Have your tried to restart Seafile?

Windows firewall is off. There’s no Av nor firewall. Maybe Xampp instance? It’s just a Win7 server with Xampp and Seafile.

On port 8082 needs to run the Seafile fileserver. This is not the case that’s why it doesn’t work.

~ nmap -A seafile.dotgainen.es -p80,8082

Starting Nmap 7.60 ( https://nmap.org ) at 2018-08-24 20:56 CEST
Nmap scan report for seafile.dotgainen.es (62.97.114.206)
Host is up (0.062s latency).
Not shown: 65533 filtered ports
PORT    STATE SERVICE VERSION
80/tcp  open  http    CherryPy wsgiserver
| http-robots.txt: 1 disallowed entry 
|_/
|_http-server-header: localhost
| http-title: Log In - DotGainen Cloud
|_Requested resource was http://seafile.dotgainen.es/accounts/login/?next=/

Service detection performed. Please report any incorrect results at https://nmap.org/submit/ .
Nmap done: 1 IP address (1 host up) scanned in 296.42 seconds

Thanks for your help.
The point is, at seafile.conf the fileserver is set up to run at 8082.
Any idea?

Anyone can help me?

Pole. Please any help?