SeaTable Error: Internal Connection Timeout

Hi, I know there is meant to be a SeaTable forum starting up soon but I don’t think it’s available yet so I was hoping to be able to get some assistance here. Basically, I’ve installed SeaTable on a Docker VM which sits behind a reverse proxy (at 10.0.0.2). SeaTable installs fine and I can create an admin user, login and view the main interface fine. I can create a table from the interface, but when I go to view it, the page never loads - it just sits there with the loading circle. From the Nginx logs, it looks like I’m getting a timeout connecting to whatever is running on port 5000 (the dtable server I think?):

[error] 22#22: *45 upstream timed out (110: Connection timed out) while reading response header from upstream, client: 10.0.0.2, server: seatable.mydomain.com, request: "GET /dtable-server/dtables/54b617dd1895499a9bfc658632b5047b?lang=en HTTP/1.1", upstream: "http://127.0.0.1:5000/dtables/54b617dd1895499a9bfc658632b5047b?lang=en", host: "seatable.mydomain.com", referrer: "https://seatable.mydomain.com/workspace/1/dtable/SomeTable/"

When I attempt to curl the internal URL from within the docker container, I get the error message:

{"error_msg":"You don't have permission to get data from the current table."}

I’m not sure if that’s the intended result or reflects some kind of configuration error.

I also get an error message when I go into the system admin area of the web UI saying “Events not enabled”, which results in parts of said admin UI not loading correctly.

Any ideas what’s going on here?

1 Like

The common case is that the URLs in your config files are not changed after you change your network.

See

Thanks for your reply. I had already updated my config, however as per the suggestion from the Github issue I added an extra_hosts line to resolve the issue with internal lookup (127.0.0.1:seatable.mydomain.com). Now I don’t get the timeout error from nginx but instead I get HTTP 500 errors returned by dtable server on port 5000. Looking at the dtable server log, I see the following:

[2020-06-09T08:29:41.003] [ERROR] dtable-server - Dtable load failed
[2020-06-09T08:29:56.991] [DEBUG] dtable-server - 0 dtables saved.

Unsure if it’s related but a few minutes later, the seatable-mysql container reports a warning message:

seatable-mysql | 2020-06-08 22:34:55 10 [Warning] Aborted connection 10 to db: 'dtable_db' user: 'root' host: '172.21.0.5' (Got timeout reading communication packets)

I suspect I’m having the same problem as https://github.com/seatable/seatable/issues/81 but not sure at this point.

Hi, I had the same error

[ERROR] dtable-server - Dtable load failed

I tried adding “127.0.0.1 $SEATABLE_SERVER_HOSTNAME” entry to /etc/hosts in the seatable container as suggested here in daniel.pan’s github issue 68.

Now the table loads without issues. But so far it works only with http and no proxy on the docker host. Still need to figure out proxy and https.

Hi,

I would be very interested if you can make HTTPS work :crazy_face:

Managed to get HTTPS working. See this issue.
https://github.com/seatable/seatable/issues/81

We will make setting https easy in version 1.1. All internal communication will use internal 127.0.0.1 address instead of external URL.

1 Like

Hey everybody,
the official SeaTable Forum is now online: https://forum.seatable.io/

Everybody who might read this: please post future questions regarding SeaTable in the new forum.
Thanks and best regards
Christoph

1 Like