Server is accessible, but cannot log in

Hi all!

I’m using seafile 9.0.2 on a raspberry pi 3b+

I’ve tried to google this issue to death, but can’t seem to find anything on it. Seafile installed fine and I could access and use it when from localhost, but after running lets-encrypt and getting certificates, I had to restart seahub and it asked me to create an admin user again… to which I got this error:

What is the email for the admin account?
[ admin email ] xxx@xxx

What is the password for the admin account?
[ admin password ] 

Enter the password again:
[ admin password again ] 

Error happened during creating seafile admin.

Seahub is started

After this, i tried to log back in but it no longer allowed me to log in. After checking the logs, all I got was this in seafile.log:

2022-06-06 22:00:23 socket file exists, delete it anyway
2022-06-06 22:00:23 ../common/seaf-utils.c(333): Use database Mysql
2022-06-06 22:00:23 http-server.c(192): fileserver: worker_threads = 10
2022-06-06 22:00:23 http-server.c(206): fileserver: fixed_block_size = 8388608
2022-06-06 22:00:23 http-server.c(221): fileserver: web_token_expire_time = 3600
2022-06-06 22:00:23 http-server.c(236): fileserver: max_indexing_threads = 1
2022-06-06 22:00:23 http-server.c(251): fileserver: max_index_processing_threads= 3
2022-06-06 22:00:23 http-server.c(273): fileserver: cluster_shared_temp_file_mode = 600
2022-06-06 22:00:33 start to serve on pipe client
2022-06-06 22:00:33 ../common/seaf-db.c(732): Failed to connect to MySQL: Plugin https could not be loaded: /usr/lib/arm-linux-gnueabihf/libmariadb3/plugin/ cannot open shared ob>
2022-06-06 22:00:45 ../common/seaf-db.c(732): Failed to connect to MySQL: Plugin https could not be loaded: /usr/lib/arm-linux-gnueabihf/libmariadb3/plugin/ cannot open shared ob>

I can’t seem to figure out why there’s no “https plugin.” Any help would be mega-appreciated!

Could you paste your seafile.conf here? Maybe a problem in the connection string?

Sure, thank you! Here it is:

GNU nano 5.4                    seafile.conf
port = 8082
host =

type = mysql
host =
port = 3306
user = seafile
password = xxx
db_name = seafile-db
connection_charset = utf8

Any idea where I might look for a solution? Is there a way turn on more verbose logs?

Not sure what the issue was, but I decided to deleted all databases created by seafile setup and re-run it and it worked!