[SOLVED] Avatars and background images not shown after upgrade to 9.0.10 community

After the small upgrade from 9.0.9 community to 9.0.10, no avatars are shown, so is there any migration script needed? How can I fix the issue?

Try to clear /tmp/seahub_cache

I actually did, but it did not work :frowning: also clearing the browser cache did not help.

Maybe, it is related to [Bug] Seafile crash after update into a Docker from 9.0.9 to 9.0.10

OK. Fixed it. I had put a symbolic link to the seahub-data directory (which is release-independent). This obviously did not work (also not in version 9.0.9), but in the old installation, the avatars directory was still filled. Conclusion is that the folder


should be used but maybe does not work with a symbolic link and


was used instead. I am not using docker, so I am a bit confused. I thought that it would be sufficient to let /opt/seafile/seafile-server-latest to the most recent installation directory while the avatars are accessed via /opt/seafile/seahub-data/avatars

The reason was simple: I am using an external reverse proxy, so I decided to not use an nginx instance on the same server. Consequently, the location for avatars is not redirected to the right directory:

location /media {
root /opt/seafile/seafile-server-latest/seahub;