[Solved] Can see but can't open/download/access files through IOS client, web access, etc

Hi all - I’ve got an odd issue that I’m trying to sort out. I’ve been running Seafile Server 6.07 on a Windows 10 machine, but had to move that PC to a different physical location/network about 6 months ago. I changed the DDNS to point to the new location, and updated the URL in the Seafile server. All PCs sync correctly with no issues, and if I’m using the Windows or Mac clients, there are no issues opening, moving, or doing other tasks with the files.

The issue I’m currently having is if I try to access the files from the IOS client (v2.9.5) or via a web browser. I can see all the files fine, but if I try to open or download one on my iPhone or web browser, it throws up an error message. I think there must be an issue with the original URL hiding in a config file somewhere, as when I try to access the file via the web browser, it says “theoriginaldomain.com took too long to respond”, not the new domain it’s pointed to.

It’s probably related, but it also seems to be preventing me from uploading camera pictures from my iPhone to the server. I hadn’t realized that was off, and when I turned it back on, it’s stuck at X pictures remain.

Any easy way to know where all domain names are located in config files and/or how to exorcise the old domain name? I ran a quick search in the Seafile server folder for the original domain name, but it came up empty.



Most probably wrong FILE_SERVER_ROOT

1 Like

Thank you very much - that was exactly it! I used the admin console on web access to reset to the correct domain and everything is working as expected. Greatly appreciate the help!