[solved] Crazy error message

android

#1

Hi,

I have installed latest android client version from f-droid. When adding my server adress, iclusive port address I get the error message that I have to add the port address. but it is added. See attached screenshot.

That’s crazy, isn’t it ? How can I solve that issue ??

By the way, I’m using syberiaOS without gapps or microG


#2

Hi,

192.168.1.92/16 is a reserved ip address for private networks and therefore unroutable, i.e. it’s impossible to reach the server if your android device is not connected to the same net. This may be the cause of your problem.

I would suggest that you use nginx or apache in front of seafile to avoid any hassle with the ports which should not be exposed at all.


#3

I can access the server via no-ip.org. I have also tried the no-ip domain for my server, but I get the same error. If I use the local ip or the no-ip domain on my laptop everything works fine.

On my other phone with the complete google bloatware it works also fine

and by the way, the crazy think is, that I have entered a port number. but it’s not recognized by the client app.
And yes, I’m using apache and it was working for more than 2 years til yesterday when I have flashed the new rom without google shit


#4

After adding the IP-adress from my router and not the domain from no-ip.org I get access again.