[SOLVED] Error "Permission denied on server"


So I have researched the subject: there seems to be a lot of reasons why one would get the “permission denied on server” error message, but I failed to diagnose my problem. Bear with me as I try to describe all symptoms…

I use Seafile Server 9.0.10 under Ubuntu 22.04.1 with a MySQL 8.0.32 database.
I tried Windows client 7.0.9 & 8.0.10 with the same results.

I have a few libraries that I’ve had for about 7 years without much problems. And today for the first time in a very long time, I have felt the need to create a new one, which I did through the web interface. It went well. I confirmed that I could create an empty Word document from there.

However, both tested clients (on 2 different computers) refuse to sync that new library with the aformentioned message. In addition, if I try again, it tells me that a task is already in progress. And if I “cancel download” and try again I get the permission denied again:

The weirdest thing is that I can access the previously created Word document with the Cloud File Browser - which I can “Save As…” and then open:

I don’t see anything relevant to the issue in the logs on the server. I do have a lot of these:
[WARNING] django.request:224 log_response Not Found: file
And 2 of those:
[ERROR] seahub.utils.timeutils:62 timestamp_to_isoformat_timestr year 163488 is out of range

Also, it all works seemlessly on the Web interface, and seaf-fsck finds no error on all libraries.

What am I missing here?

Edit: I shall add that I managed to share that new library to a new user who gets the same error message when attempting to sync the library, and who managed to upload a file from the Cloud File Browser, which the owner can then see and download.

Edit: That was my bad, I was looking around Seafile when the problem lied in my Apache configuration all along. A stupid missing authorization for /seafhttp.