SOLVED: Error uploading files - FILE_SERVER_ROOT set correctly


#1

Seafile server 6.0.6
Centos 7.2
Nginx 1.10.2
Letsencrypt ssl certs

Upload via safari or chrome doesn’t work.
Webdav seems to work.
Seafile iOS client does not work (connects to server but can’t upload / download)

When i try to upload via safari or chrome i get an “unknown error”.

How can I debug this with Chrome so I can get some hints what is happening?
What should I look at?

It would be great to get some advise.

Chris


Seafile with nginx and fast-cgi
#2

Hi guys

I thinkI figured out how to debug with Chrome.
The error I get is this:

https://seafile.example.com/ajax/repo/b28192f5-0f4a-4787-8594-9ef485ac3416/file_op_url/?main.621ee2b3ba7f.js:221 GETop_type=upload&path=%2F&_=1480021587137 401 (UNAUTHORIZED)

Would that be helpful to help me?

Cheers, Chris :wink:


#3

And there is also another error sometimes:

https://seafile.example.com/seafhttp/upload-aj/580d07ab-397d-45e5-9fdd-aa45cd286b14 net::ERR_NAME_NOT_RESOLVED

Hard to understand what this is.

Can someone tell me how to solve this?


#4

means the server is not accessible, maybe you should check your server (which is https://seafile.example.com in your case) or your proxy settings.


#5

Dear Lian
Thanks for taking the time.
This is most embarrassing for me though.
Because I actually have misspelled my FILE_SERVER_ROOT…

I swear to you that triple quadrible checked it. I mean: I even put it in the title…

Oh dear…

Anyways, sorry again for that and have a good weekend,

Chris