[SOLVED] How to reset or reinstall seafile?

I have just setup a new Seafile Pro server for my wife and I. Right after getting it installed and uploading a file or two to test. I did two things:

  1. Moved to an S3-compatible backend using the instructions : at …/deploy-seafile-pro-edition/storage-backends/amazon-s3-backend
  2. Turned on storage backend encryption using these instructions: …/deploy-seafile-pro-edition/storage-backends/storage-backend-encryption

Now that this is setup, I can’t get full-text search working, even with files uploaded AFTER both steps above. I didn’t migrate the existing test data, because I don’t really care about it. What I would like is to completely start over with all stored files and history in Seafile. I won’t lose anything important. Is this possible?

I have run seaf-fsck and it doesn’t appear to find anything.
The error I am seeing is:
~ /opt/seafile/seafile-server-latest/pro/pro.py search --update

05/30/2020 21:20:58 [DEBUG] seafes:85 update_repo: latest_commit_id: 2159c77722b5f6729faf630ce50017b1725e83fa, status.from_commit: None
05/30/2020 21:20:58 [WARNING] seafes:42 update_files_index: Failed to read object 059a8a8b-fa2b-41ce-9ffa-d0bce12b822b/2159c77722b5f6729faf630ce50017b1725e83fa: Invalid decrypted data
05/30/2020 21:20:58 [DEBUG] seafes:94 thread_task: Queue is empty, worker1 worker threads stop
05/30/2020 21:20:58 [INFO] seafes:119 thread_task: worker1 worker updated at 2020-05-30 21:20 time
05/30/2020 21:20:58 [INFO] seafes:124 thread_task: worker1 worker get 0 error
05/30/2020 21:20:59 [INFO] seafes:172 extract: extracting ad4b33ba-4187-4f8b-97a5-43f10b159482 /seafile-tutorial.doc...Error: Unable to access jarfile /opt/seafile/seafile-server-latest/pro/python/seafes/poi/ExtractText.jar
05/30/2020 21:20:59 [ERROR] seafes:176 extract: failed to extract /seafile-tutorial.doc: [Errno 32] Broken pipe
05/30/2020 21:20:59 [DEBUG] seafes:94 thread_task: Queue is empty, worker0 worker threads stop
05/30/2020 21:20:59 [INFO] seafes:119 thread_task: worker0 worker updated at 2020-05-30 21:20 time
05/30/2020 21:20:59 [INFO] seafes:124 thread_task: worker0 worker get 0 error
05/30/2020 21:20:59 [INFO] seafes:38 clear_worker: All worker threads has stopped.

Note that I do not have “seafile-tutorial.doc” in any library right now. I deleted it early on before migration.

I wonder if I could just do this to start fresh

  1. stop seafile and seahub
  2. drop and recreate the three mariaDB databases I used for seafile
  3. clear all objecrs from the s3 buckets.
  4. re-run the official install script.

I was impatient, so I tried the above steps to reset and it worked perfectly. Also, I figured out that the error that I reported was actually because I had office doc conversion turned on, but didn’t have Libreoffice/UNO install. I have turned off that feature for now.

Good work and good information to know…

Can you add [ SOLVED ] to the beginning of your title, please?