Stop showing relative dates for very old files

For very old files, Seadrive used to display the timestamp in ISO8601 format (eg. 2005-01-01). The public “shared links” do still display it this way:

However, after upgrading from 6.3.4 to 7.0.4, it’s just showing relative timestamps for everything, which is much less useful:

Additionally, it does not display the full date/time on hover, so there’s no way to get a more granular timestamp than “17 years ago”

Was this an intentional change? Is it possible to restore the old behaviour?

Seadrive or Seahub?

This is in Seahub. I guess it’s a result of the new React-based UI in 7.0.

Looking at the code, it seems like there’s no way to change it, it always uses relative time…

I’m not sure what logic the old version used to determine to show relative time vs full timestamp, but it’s probably worth porting the same logic across.


Can you please check: This problem should be solved in Seafile 7.0.8.

If yes, please mark this post as “solved”

I don’t see 7.0.8 on the download page at, only 7.0.4 (which is what I’m already using). Is 7.0.8 only a Pro release? I’m on the open source version.

Didn’t know you are on CE. Well, I suppose you will see the absolute dates in 7.0.5 CE then.

I just updated to 7.0.5 and don’t see this change. Is it not in CE yet?

Hi Daniel15,
I just checked again - in CE and PE. The result is a bit surprising: Absolute dates are shown in both editions on the library level (see below). Absolute dates are not available on the folder/file level.