Stuck at 'migrating avatars'

Happy Friday,

I am trying to upgrade a SeaFile Pro install from 6.0.12 to 6.1.9 and am stuck at the step where you run the script from the upgrade folder.

The last version in the folder is, if I run that it gets stuck at ‘migrating avatars’. I reverted to a previous snapshot and figured i’d ask here what the correct process is before I tried again.

Thanks for any help

Try to add at a “set -x” on the top of the script after the shebang line and rexecute the script and see why it hangs.

The last step was

mv /opt/seafile/seafile-pro-server-6.1.9/seahub/media/avatars/default-non-register.jpg /opt/seafile/seafile-pro-server-6.1.9/seahub/media/avatars/default.png /opt/seafile/seafile-pro-server-6.1.9/seahub/media/avatars/groups /opt/seafile/seahub-data/avatars

I went ahead and commented out the database update and avatar move phases and then just ran the final two and was successful as far as I can tell.

Could have permissions been an issue?

Same Problem here. I followed exactly upgrade manual and started.
I firstly had Problems to turn off seahub as it still was running so i found pids and killed them. Than the Update SCript worked until migrating Avatars.

Any Solutions on that?

Can i correct Avatar Link with following Command?
FAQ is not that detailed…

# ln -s ../../../seahub-data/avatars /home/seafile/seafile-pro-server-6.3.2/seahub/media

rm /home/seafile/haiwen/seafile-server-XYZ/seahub/media/avatars -R

ln -s …/…/…/seahub-data/avatars /home/seafile/haiwen/seafile-server-XYZ/seahub/media/avatars

1 Like