Unable to Connect

After installing Seafile Community edition for Docker on Ubuntu 22.04, when I connect to the server via a web browser (either by IP address or hostname), I get a message saying “Unable to Connect”.

Using docker-update logs -f shows that the server has started. There are no entries in the seafhttp.access.log or error.log.

Not sure what to do from here.

can you post your config gunicorn.conf.py

import os

daemon = True
workers = 5

# default localhost:8000
bind = ""

# Pid
pids_dir = '/opt/seafile/pids'
pidfile = os.path.join(pids_dir, 'seahub.pid')

# for file upload, we need a longer timeout value (default is only 30s, too short)
timeout = 1200

limit_request_line = 8190

try with this,

# default localhost:8000
bind = "

and restart seafile
and connect with address:


That didn’t work, still can’t connect. From Firefox on both IP address and domain:

This site can’t be reached
205.xxx.xxx.xxx refused to connect.
* Checking the connection
* Checking the proxy and the firewall

server is in a local network?
Or are you trying on a remote server?

It’s a remote server

to connect there are several ways the first time you install seafile docker.

  1. nginx installed with let’s encrypted certificates.
    in this case port 443 TCP will be used with the domain name, you will have to open port 443 on the server using the firewall.
  2. you can access seafile directly without a domain name (with the ip)
    in this case it will be necessary to open port 8000 TCP to access the interface.
    port 8082 and 8083 for Seafile desktop client.
    be careful if you use a direct connection (with ip) without using Nginx and let’s encrypt your communication will not be encrypted.

and if you connect with the ip, the address will be written like this:

By default the ports 8000 and 8082 need to be opened in the firewall for incoming TCP connections.and 8083 for Server Notification
If you run Seafile behind Nginx/Apache with HTTPS, you only need to open port 443 TCP

I assume it’s running nginx because this was installed from the fully containerized docker-compose version of Seafile. https is also enabled with Let’s Encrypt.

I opened the port using ‘sudo ufw allow 443’. Tried accessing with both the domain name and direct IP address using all ports (80, 8000, and 443). Still no success connecting. Also restarted Seafile using docker-compose restart.

Never mind. After double checking docker-compose.yml, the line for port 443 was commented out. Removing the comment fixed it.

1 Like