Unable to download directory "temp": size is too large

Clicking on download shows:“Unable to download directory “temp”: size is too large.”!

Just look here: http://manual.seafile.com/config/quota_and_size_options.html

#Change upload/download size limit.

In seafile.conf:

# Set maximum upload file size to 200M.

# Set maximum download directory size to 200M.
1 Like

Thanks alot. Is 200MB the general maximum for these settings?

No, we have it set higher on our systems. But remember, the loading / creating of a zip can take some time.

Thanks alot but do you remember any problems activating these settings?
On one test system I’ve experienced that max_upload_size=200 and max_download_dir_size=200 don’t have any effect (always size is too large error).

port = 8082
max_upload_size = 25600
max_download_dir_size = 2048

Copy this exactly to your config. It should work.
EDIT: Did you restart the server since the setting?

1 Like

Wow. I really had to restart the server. Usually I avoid linux server restart because somehow I think/thought this is not necessary under Linux.

Anyway: thanks alot. ZIP-Download works now!

I was talking about the seafile software. But good, that it works now.

Seafile service I’ve restarted of course but this was not enough somehow.

Saved config changes first, then stopped both seafile and seahub services, and restarted seafile before seahub service? (Just for future reference…)

Yes that should work and is the right way.