Unable to download/upload files. Unable to connect

I tried setting up a seafile server on my Ubuntu server running apache2. I was able to get the seafile server working enough to browse to it but when trying to upload i get connection refused and when trying to download the “seafile-tutorial.doc” file i get to a page that “unable to connect”. The only change i see is that it switches to https when downloading the file.
Firewall is open to all connections between my PC and my server.
I use Pi-hole as DNS and put in the lan.list:
“IP address of server” seafile-test,com

That allowed me to browse to seafile-test,com and got the main page as well as client connects. issue seems to only be when trying to transfer files. Been scouring sites but see similar issues but I don’t have the same problems or config issues they have. I followed a guide from Website for Students.

yes i know the fqdn has a comma but i was getting error when posting saying i can’t add link. those are correctly with a period in the actual config

think i may have figured it out haha. Let’s see, standby

ok no i basically caused apache to explode. I tried to go through to enable apache with HTTPS but being the newb i am i failed miserably and lost apache all together. I got it working again with http but still not able to download.
Is SSL/HTTPS setup needed to get this part to work or is it just a secure option when dealing with it out on the web (not configured that way yet just using it on the LAN).