Unable to start Seahub on Centos v7 new installation

I’m trying to upgrade my Seafile development server from v9.x to v10.x running on Centos v7. When I try the upgrade, I get this error starting Seahub. Seafile service starts fine.

Traceback (most recent call last):
File “/opt/seafile/seafile-pro-server-10.0.9/check_init_admin.py”, line 19, in
from seaserv import ccnet_api
ModuleNotFoundError: No module named ‘seaserv’

I’ve just built a new virtual machine from scratch with this basic steps:

  1. MariaDB v11.1 server and MariaDB-Devel
  2. Nginx web server
  3. Python 3.7.17 (has to be compiled)
  4. Seafile pro following instructions (pip components, Java)

Exactly the same problem. I’m missing something obvious!

I’ve just built a new Rocky Linux 9 VM which includes much later versions of the core modules. Same error.

Try to create the symbolic link ./seafile-server-latest/seafile/lib/python2.7 to ./seafile-server-latest/seafile/lib/python3

I can’t see a python2.7 in lib but there is one in lib64. Will give that a go…

Tree listing of seafile folder

Later… that didn’t help unless I need to do something else. Don’t know Python very well but will go and do a bit of reading around Python import modules.

I obviously did something wrong before as I restored the Rocky Linux VM and tried it again with these commands:

cd /opt/seafile/seafile-server-latest/seafile/lib64
ln -s python2.7 python3

This allowed me to specify the admin username and password. Still fails to start but at least I’ve moved forward and I can get seahub.sh to run the Python commands it needs.

LC_ALL is not set in ENV, set to en_US.UTF-8
Starting seahub at port 8000 …
Error:Seahub failed to start.
Please try to run “./seahub.sh start” again

I’ll do a separate post after I’ve looked in the logs to see why it’s not starting. Will go back through the install instructions. Might have missed something.

But as an aside, if Seafile is supposed to run with Python3, then shouldn’t this symbolic link be in the TAR file? I’ve been doing some Python training lately but haven’t got to the bit on packages so don’t know whether this folder/module structure is a Python or Seafile thing.