Unable to sync enpass on android with seafile over webdav

My config is the following:

[nas running seafile pro 6.0.12 with webdav extension] + nginx https letsencrypt as reverse proxy --> cloudflare strict ssl --> the world

Syncing the enpass desktop client (archlinux x64) works fine, no problem at all. But when it comes to android here I do have a (big) problem. The first sync is correctly done and my db is on the phone.

But after that, every time I open Enpass I got an error -119 couldn’t connect to cloud service. Of course, my nas and seafile are up and running because I can access them using davfs2 or chrome, for example.

So I tried to look into logcat and I found the following issue:

 W/HttpMethodBase(1735): Cookie rejected: "$Version=0; 

__cfduid=$TOKEN; $Path=/; 

$Domain=.MYDOMAIN.eu". Illegal domain attribute ".MYDOMAIN.eu". Domain of origin: "MYDOMAIN.eu"

Strangely enough, if I try to setup the dav folder with Solid Explorer I can see the same problem on the logs.
But if I try to mount the dav folder using total commander + webdav plugin (android) then everything works fine.

My guess is that there is a problem with the jakarta httpclient library because also with solid explorer I am getting the same error with the same user agent (3.1)

Inside the file /var/log/nginx/seafdav.access.log I see that HTTP 401 and 207 are triggered when trying to sync with the enpass mobile client. The error log is empty and also the file logs/seafdav.

Is is a specific problem from that library/app or is there something I can do on my side?

PS I don’t post the config because they are the same ones you can find here: https://manual.seafile.com/deploy/

if I disable cloudflare then everything works…