Unable to upload/delete files through reverse proxy4

Hello everyone!

I am facing that issue since I tweaked apache2. I am running Ubuntu 16:04 with Apache 2.4 and TLS 1.3.

Basically, on the web/client interface, I am not able to upload (forbidden) or delete (generic error) files.

I am perfectly able to create, download and share files.

If I access Seafile by its local IP/port, everything is working.
I am experiencing the above issue when I am accessing Seafile by its public url behind a reverse proxy.

I followed the instruction in the Seafile manual to configure correctly Apache & Seafile.

I tried to change few things in the vhost and the config without success. I also checked in the log but there were no error at all. Even with the docker version it does exactly the same.

Below will be attached every userful config files.

Vhost seafile-le-ssl.conf:

    <IfModule mod_ssl.c>
<VirtualHost *:443> 
	ServerName seafile.jacobdorais.ca
  Alias /media  /etc/Seafile-Server/seafile-server-latest/seahub/media

  <Location /media>
    Require all granted

  RewriteEngine On
  ProxyPass /seafhttp
  ProxyPassReverse /seafhttp
  RewriteRule ^/seafhttp - [QSA,L]

  SetEnvIf Authorization "(.*)" HTTP_AUTHORIZATION=$1
  ProxyPreserveHost On
  ProxyPass /
  ProxyPassReverse /
# Include /etc/apache2/conf-available/emby.conf

	SSLCertificateFile /etc/letsencrypt/live/seafile.jacobdorais.ca/fullchain.pem
	SSLCertificateKeyFile /etc/letsencrypt/live/seafile.jacobdorais.ca/privkey.pem
	Include /etc/letsencrypt/options-ssl-apache.conf


USER_NAME = Server
ID = 7d08d938bf54b6e8ae33abbcdce5d7d6c446d337
NAME = Server
SERVICE_URL = https://seafile.jacobdorais.ca

PORT = 13419

ENGINE = mysql
PORT = 3306
USER = seafile
DB = ccnet-db


# -*- coding: utf-8 -*-
SECRET_KEY = "lbg*gmzdt)r3cw3+a!nkcnp&slfp(u#%xgqcv^dztp)c^r-r!+"

    'default': {
        'ENGINE': 'django.db.backends.mysql',
        'NAME': 'seahub-db',
        'USER': 'seafile',
        'PASSWORD': '5U9z-VRX',
        'HOST': '',
        'PORT': '3306'

FILE_SERVER_ROOT = 'https://seafile.jacobdorais.ca/seafhttp'

Thank you for your help regarding that!

Disable TLSv1.3, and enable 1.1 and 1.2, seafile is not compatible with the latest protocol (sadly).