Unable to upload files (solved)

Hi guys!

My setup…EC2 instance with an s3fs mount for seafile-data. This mount is linked from /media/seafile-data to /home/ubuntu/seafile/seafile-data. Seafile install with MySQL and nginx.

Seafile seems to run and show the currently empty libraries (since it’s a brand new install). I can create users etc with no issues. But when I try to upload a file, I get a “network error” on the upload box in the browser. If using the client, the file gets stuck at 0% and nothing happens. I don’t see any current errors in ccnet.log, seafile.log, controller.log or seahub.log. Just in case I “chown-ed” all the files/folders in the s3fs mount to ensure they belong to the seafile user. But I don’t seem to see what’s the issue.

/seafile/logs$ tail *
==> ccnet.log <==
[08/13/20 07:15:40] …/common/connect-mgr.c(515): Opened port 10001 to listen for incoming peer connections
[08/13/20 07:15:40] socket file exists, delete it anyway
[08/13/20 07:15:47] start to serve on pipe client
[08/13/20 07:16:03] start to serve on pipe client
[08/13/20 07:16:04] start to serve on pipe client
[08/13/20 07:16:07] start to serve on pipe client
[08/13/20 07:18:42] start to serve on pipe client
[08/13/20 07:18:42] start to serve on pipe client
[08/13/20 07:18:42] start to serve on pipe client
[08/13/20 07:22:29] start to serve on pipe client

==> controller.log <==
[08/13/20 06:24:09] seafile-controller.c(191): starting seaf-server …
[08/13/20 06:24:09] seafile-controller.c(79): spawn_process: seaf-server -F /home/ubuntu/seafile/conf -c /home/ubuntu/seafile/ccnet -d /home/ubuntu/seafile/seafile-data -l /home/ubuntu/seafile/logs/seafile.log -P /home/ubuntu/seafile/pids/seaf-server.pid -p /home/ubuntu/seafile/seafile-server-7.1.4/runtime
[08/13/20 06:24:09] seafile-controller.c(94): spawned seaf-server, pid 4719
[08/13/20 06:37:36] seafile-controller.c(471): shutting down all services …
[08/13/20 07:15:40] seafile-controller.c(159): starting ccnet-server …
[08/13/20 07:15:40] seafile-controller.c(79): spawn_process: ccnet-server -F /home/ubuntu/seafile/conf -c /home/ubuntu/seafile/ccnet -f /home/ubuntu/seafile/logs/ccnet.log -d -P /home/ubuntu/seafile/pids/ccnet.pid
[08/13/20 07:15:40] seafile-controller.c(94): spawned ccnet-server, pid 1446
[08/13/20 07:15:40] seafile-controller.c(191): starting seaf-server …
[08/13/20 07:15:40] seafile-controller.c(79): spawn_process: seaf-server -F /home/ubuntu/seafile/conf -c /home/ubuntu/seafile/ccnet -d /home/ubuntu/seafile/seafile-data -l /home/ubuntu/seafile/logs/seafile.log -P /home/ubuntu/seafile/pids/seaf-server.pid -p /home/ubuntu/seafile/seafile-server-7.1.4/runtime
[08/13/20 07:15:40] seafile-controller.c(94): spawned seaf-server, pid 1447

==> seafile.log <==
[08/13/20 07:15:40] http-server.c(176): fileserver: worker_threads = 10
[08/13/20 07:15:40] http-server.c(191): fileserver: fixed_block_size = 16777216
[08/13/20 07:15:40] http-server.c(206): fileserver: web_token_expire_time = 3600
[08/13/20 07:15:40] http-server.c(221): fileserver: max_indexing_threads = 1
[08/13/20 07:15:40] http-server.c(236): fileserver: max_index_processing_threads= 3
[08/13/20 07:15:40] http-server.c(258): fileserver: cluster_shared_temp_file_mode = 600
[08/13/2020 07:16:03 AM] start to serve on pipe client
[08/13/2020 07:16:06 AM] start to serve on pipe client
[08/13/2020 07:16:07 AM] start to serve on pipe client
[08/13/2020 07:18:42 AM] start to serve on pipe client

==> seahub.log <==

*: seahub.log is currently empty.

Any hints?

Check SERVICE_URL in ccnet.conf and FILE_SERVER_ROOT in seahub_settings.py.

Or you can use the parameters in the web settings.

The screenshot shows the default values.

Thanks for the very fast reply! So far mine look by default as follows:
SERVICE_URL: https://mydomain.com:8000
FILE_SERVER_ROOT: https://mydomain.com:8082/seafhttp

These ports 8000 and 8082 came by default. FILE_SERVER_ROOT didn’t have /seafhttp by default. I added it, but it didn’t seem to change anything after restarting the services. Are these ports correct?

5

with a domain name you do not have to indicate the ports

Thanks! That seems to have fixed it. By the way, seems it didn’t like the FILE_SERVER_ROOT line at seahub_setting.py. That wasn’t there, and when manually added it refused to start. But changing it from the UI worked anyway.

I’m gonna keep checking, but I managed to upload a file successfully.

Thanks a lot!

1 Like

Please indicate that this discussion is resolved ; Thanks