Upgrade: from 8.0.8 to 9.0.2 CE - Half user accounts missing

Hello everyone,

I just upgraded from 8.0.8 to 9.0.2 CE:

  1. I stopped the Seafile & Seahub services.
  2. I installed the new pip dependency.
  3. I executed the upgrade_8.0_9.0.sh script and it ran without any apparent errors.

I then started back Seafile & Seahub, no apparent error there again.

I opened up the web UI and tried to sign in to my account, but it gave me an invalid username or password error. I then tried to reset my password from there, but it said my account didn’t exist.

So I tried to sign in to few accounts there, half of the accounts I had (including the admin) are apparently no longer existing… The ones that still exist work just fine, no missing files/libraries.

At that point, I tried going back to 8.0.8 by running the minor-upgrade.sh script, but I get a server error when opening the web UI.

I have backups of MySQL & the Seafile folder from this morning in case it is needed. That is not an easy fix though as I am sharing MySQL with a ton of other services.

Any help would be greatly appreciated!
Thank you!

Well, I am not too sure what happened there, I tried to sign in again this morning and all the accounts are working now.