Upgrading Seafile Server from Docker Community to Docker Pro


#1

I am currently running a docker-deployed Community version, and would like to either upgrade, or migrate, to a docker-deployed Pro version. Thus far, I’m not having a ton of luck.

I have successfully installed a Docker deployed Pro version (yes, I have a license) on a different server, but I am not able to migrate the data from our Community server. Likewise, I am having no luck upgrading our docker-deployed Community version to Professional version. I’ve tried following the various guides, but I keep running to several different errors (either the entire site is simply broken or I get an error “IOError: [Errno 2] No such file or directory: [DOCKERPATH]/rootfs/opt/seafile/ccnet/seafile.ini”).

I’m not entirely sure as to what I am doing wrong, so any assistance would be appreciated. There doesn’t seem to a clear guide with regards to upgrade from a docker-deployed community version to a docker-deployed Professional version. Is there a recommended path for this?


#2

Okay - I figured this out, but it wasn’t intuitive. So I essentially followed the backup/restoration guide in the docker deployment documentation - I backed to everything in my “community” server as indicated here:

https://manual.seafile.com/deploy/deploy_with_docker.html

And “restored” it to the “professional” server as indicated here:

https://manual.seafile.com/deploy_pro/deploy_with_docker.html

And once that was done, I ran the pro.py command to update everything:

docker exec seafile /opt/seafile/seafile-pro-server-6.3.9/pro/pro.py setup --migrate

The whole process was pretty quick - however, it would be nice if there was some documentation (given “docker” is the preferred deployment method), as this took me a few hour of trial and error to work out and I’m still not 100% certain why this path worked.


#3

So this was working, but upon restarting seafile after changing some settings, I am now getting the following error:

[01/04/19 15:48:44] ../common/session.c(139): using config file /opt/seafile/conf/ccnet.conf
[01/04/19 15:48:44] ../common/ccnet-db.c(131): Failed to get database connection: Failed to connect to MySQL: Access denied for user 'seafile'@'localhost' (using password: YES).
[01/04/19 15:48:44] user-mgr.c(1080): Failed to create user db tables.
failed to run "ccnet-server -t"

I believe this was the same error that was seen here:

But I’m not sure what I am doing differently. Any ideas?


#4

Okay - so I’ve figured out the MySQL issue (retain the password from the initial Professional installation) - but now all of the Library files, the upload links, and download links that were initially working when I first got the migration running are no longer there. I’ve tried importing the databases and the data several times.

I’m starting to get a tad frustrated - it’s taken two days (!!) to migrate from the Community to a paid Professional version using docker and it is still not working. So any help at all would be appreciated.