Visualisation problems with NGINX reverse Proxy

I have a visualisation problem when I set up the NGINX Reverse Proxy on as Raspi3

When I do configuration with seafile and seahub without nginx everything is fine.

But as soon as I build up the nginx configuration, the seahub interface is like this:

I tried setting up NGINX with a different service like openHab and everything is just fine.

EDIT: Connection with Apps and windows- clinets : upload, download… everything works fine…

Any Ideas?

That’s probably an additional or missing trailing slash somewhere in your Nginx config, maybe actually near the section for the media folder.

Ah, you’re using a non-root domain setup.

Did you customize some of the Seahub settings like mentioned in ?
The *_URL variables need to match what you configured in Nginx, especially MEDIA_URL.
Maybe use the Developer Tools of your browser to find out which urls are tried.

Yes I’m sure. And I already tried the root domain setup… same result.

Could you click on one of the 404’d requests and look at the actual full url, please?

and after login:

Oh I found another. Did You mean this one?

Thanks for the help. I found the problem in the user permissions on the media folder

Yes, I meant those (the request urls you posted before weren’t the ones that failed) - you see that it tries to access the subpath /seafmedia/ which you did not configure in the Nginx configuration you posted above (just location /media there).

Based on your Nginx configuration and your last post it isn’t quite plausible that this would have been the root cause, but if it works, it’s okay.

When using fastcgi, the location /media directory is not needed in the configuration and is why you are having issues. Remove that bit and clear browser cache should fix this issue.

I meet the same problem, dig into the Chrome developer panel, I found those error message:

it was my Nginx’s missing, so I add include mime.types inside the Nginx-> http’s config, all works well.