Web Api get client url

server

#1

Hello everyone!
I tried to user curl to obtain a auth token from myserver,
and then I tried to get the client login url with that token.
but i got following response:

BillydeMacBook-Pro:~ Billy$ curl -H 'Authorization: Token 369f32fa968761ff4492e45d7fe38cd6a7ea1dd7' https://seafile.babustudio.net/api2/client-login/ {"detail":"Method \"GET\" not allowed."}

According to the manual, the only error expected is 403 invalid token, but i got this, 405 method not allowed.
Does anyone know how to deal with this? I will appreciate that if you can help me out.


#2

For me the response for the same request is invalid token (I’ve queried your server).

curl -H 'Authorization: Token 369f32fa968761ff4492e45d7fe38cd6a7ea1dd7' https://seafile.babustudio.net/api2/client-login/
{"detail":"Invalid token"}

#3

I am sorry that I did not provide the correct token for safety considerations. Here is the right token:{"token":"469f32fa968761ff4492e45d7fe38cd6a7ea1dd7"} Please help me solve this problem, I really appreciate that you replied to me!:heart_eyes:


#4

Make sure to delete the token if you haven’t created it for some test account.

With the working token I get the same result as you.

curl -H 'Authorization: Token 469f32fa968761ff4492e45d7fe38cd6a7ea1dd7' -X GET https://seafile.babustudio.net/api2/client-login/
{"detail":"Method \"GET\" not allowed."}

Without token it says

~ curl -X GET https://seafile.babustudio.net/api2/client-login/
{"detail":"Authentication credentials were not provided."}⏎

Only with a working token it says GET not allowed.

For me it looks like the documentation is wrong.

@daniel.pan


#5

So, how can I work it out? Does anyone experience the same as me?
@shoeper Do you have another seafile server which is not in production, can you help me try to get the client login url with a right token generated from that server in order to make sure that it wasn’t my server’s fault?


#6

And additional information here:

Seafile Server Version: CE 6.2.5 (has just been upgraded to 6.3.2)
Database using: SQLite
Operating System: Ubuntu 16.04.3 LTS x64

If you want any more details about my server, please reply to me.
Thanks.


#7

After I upgraded the seafile server to 6.3.2, the same error still occurs.