WebDav constant errors after GC scipt

After running the GC script in the docker container (which includes shutting down the server and restarting it again) i recognized a suspiciously high load on the server for a sunday and checked the logs. The displayed error message repeats all the time within an intervall of 1 min.

I guess there is something wrong in the script regarding the server restart, because after restarting the whole docker-compose instance the error disappears and the load goes back to normal.

2022-03-20 16:22:58.812 - <139663332140864> wsgidav.dc.seahub_db        INFO    :  Init seahub database...
2022-03-20 16:23:00.170 - <139663332140864> wsgidav.wsgidav_app         INFO    :  WsgiDAV/3.0.4 Python/3.8.10 Linux-5.4.0-91-generic-x86_64-with-glibc2.29
2022-03-20 16:23:00.170 - <139663332140864> wsgidav.wsgidav_app         INFO    :  Lock manager:      LockManager(LockStorageDict)
2022-03-20 16:23:00.170 - <139663332140864> wsgidav.wsgidav_app         INFO    :  Property manager:  None
2022-03-20 16:23:00.170 - <139663332140864> wsgidav.wsgidav_app         INFO    :  Domain controller: SeafileDomainController()
2022-03-20 16:23:00.170 - <139663332140864> wsgidav.wsgidav_app         INFO    :  Registered DAV providers by route:
2022-03-20 16:23:00.171 - <139663332140864> wsgidav.wsgidav_app         INFO    :    - '/:dir_browser': FilesystemProvider for path '/opt/seafile/seafile-server-8.0.8/seahub/thirdpart/wsgidav/dir_browser/htdocs' (Read-Only)
2022-03-20 16:23:00.171 - <139663332140864> wsgidav.wsgidav_app         INFO    :    - '/seafdav': SeafileProvider for Seafile (Read-Write)
2022-03-20 16:23:00.171 - <139663332140864> wsgidav.wsgidav_app         WARNING :  Basic authentication is enabled: It is highly recommended to enable SSL.
2022-03-20 16:23:00.171 - <139663332140864> wsgidav                     WARNING :  Could not import lxml: using xml instead (up to 10% slower). Consider `pip install lxml`(see https://pypi.python.org/pypi/lxml).

This error seems to have its origin at the end of the GC script. It seems that the seafdav server is not shutdown properly while stopping the server.

seafserv-gc run done

Done.

[seafdav] is running, pid 1714942. You can stop it by: 

        kill 1714942

Stop it and try again.

Did you ever find a solution to this? I have this happen regularly (using Docker too).

Yes and no. I solved it by disabling WebDav because it was no longer needed on our Seafile instance.