WSL: mount -t drvfs no longer works for SeaDrive (Windows)

I’ve noticed that somehow it’s no longer possible to mount the SeaDrive S: in Windows Subsystem for Linux (WSL):

$ sudo mount -t drvfs S: /mnt/s
[sudo] password for ***username:
mount: /mnt/s: wrong fs type, bad option, bad superblock on S:, missing codepage or helper program, or other error.
$ uname -a
Linux ***computername 4.4.0-17763-Microsoft #379-Microsoft Wed Mar 06 19:16:00 PST 2019 x86_64 x86_64 x86_64 GNU/Linux
$ cat /etc/os-release
VERSION="18.04.2 LTS (Bionic Beaver)"
PRETTY_NAME="Ubuntu 18.04.2 LTS"

This used to work a few months ago. So I guess my questions are:

  • Is it only my machine or can others reproduce it?
  • Is there a workaround?
  • Is SeaDrive somehow using non-standard techniques that make it incompatible with current drvfs?

Hmm, after some more research, I found that drvfs support for various filesystems / filsystem drivers seems to be rather incomplete. There are multiple issues on Microsoft’s WSL Github repo about such limitations. (I’m just puzzled by the fact that, AFAIR, it worked just fine the last time I had a need for it.)

So for now the easiest workaround is to actually synchronize the library and access those files from within WSL.

Use SeaDrive for Linux directly in WSL

Is this actually working? Doesn’t SeaDrive require a running GUI? I thought WSL was CLI-only (at least without crude hacks).

No you don’t need a GUI. Just FUSE capabilities. And you you also use X for Windows and mount .sock into WSL, there are millions of methods, UNIX is much more flexible than Windows users expect :slight_smile:

Good to know, thanks for the tips.
As for the “Windows users”, that I’ll have to reject emphatically :wink:
I’m somewhat forced to use it, since my current Thinkpad is having some annoying suspend/resume reliabilty issues with Linux. (Maybe even dangerous: it seems suspended but is heating up…) But that’s my first real exposure to Windows in decades. WSL makes it bearable.

Anyway, did you actually try what you’re proposing? I’d really be interested to hear, since my understanding was that missing FUSE support was one of the many, many limitations of WSL when compared to native Linux. I’ve given up on trying more advanced things with WSL. On the one hand it’s truly marvelous, on the other hand it’s frustrating as hell if you’re coming from a native system.

Never worked with WSL, just with Cygwin long ago. Both things should theoretically work with WSL, too.

What Thinkpad? Thinkpad have usually a very good Linux compatibility, and even have LinuxVendorFirmwareService now, so you get full BIOS ugprades.

That’s what I thought, too… That’s probably only for the 100%-business oriented models, not novelty devices like the 1st gen Thinkpad Yoga.
Anyway this is getting off-topic.