ZIP download trouble

8.0.5 server is installed on debian (this problem also have been on a previous version of SF). Server on a virtual machine, from host to the VM with setup of proxy. The problem with downloading ZIP - directories and files of small size are downloaded well, directories larger than 5Mb - the message “Packing… 0%” hangs. Temporary zip files are created in the httptemp directory well.
If in browser (Firefox) call development panel by pressing F12 - packing goes step by step and all works correctly. If in browser switch off development panel, this problem appears again.
What settings should I try to modify? Any ideas?

Any ideas? I have updated server to 8.0.6, but nothing changes

I cannot reproduce your problem. I successfully downloaded ZIP files of various sizes in excess of 5MB. The largest ZIP I created was 80MB. I got an internal server error when trying to ZIP-download a 1GB folder.

I recorded a video from the screen, at 11 seconds of the video I click F12 in the browser and the process ends successfully. If you do not press anything, then it will hang.
Youtube Link

Thanks for the video. I believed you without it.

Yet, I still cannot reproduce the problem.

Have you checked your server settings? Nginx and seaf-server?

I have Seafile installed on the Debian 10 virtual machine with Apache, on the host Debian 10 with Apache ( too. From the host goes proxy to the virtual machine. Seafile server installed on new virtual machine according to official documentation, IP

Host configuration Apache:

RewriteEngine On
RewriteCond %{SERVER_PORT} ^80$ [OR]
RewriteCond %{HTTP} =on
RewriteRule ^(.*)$$1 [R=301,L]
<IfModule mod_ssl.c>
AllowEncodedSlashes On
SSLEngine on
Include /etc/letsencrypt/options-ssl-apache.conf
SSLProxyEngine On
SSLProxyVerify  none
SSLProxyCheckPeerCN off
SSLProxyCheckPeerName off
SSLProxyCheckPeerExpire off
SSLProtocol all -SSLv3 -TLSv1 -TLSv1.1
SSLCertificateFile /etc/letsencrypt/live/
SSLCertificateKeyFile /etc/letsencrypt/live/
ProxyRequests On
ProxyPreserveHost On
ProxyVia full
ProxyPass        /
ProxyPassReverse /

Seafile Apache config:

<VirtualHost *:80>
DocumentRoot /var/www/
Alias /media /home/sf/seafile-server-latest/seahub/media
AllowEncodedSlashes On
RewriteEngine On
<Location /media>
Require all granted
ProxyPass /seafhttp
ProxyPassReverse /seafhttp
RewriteRule ^/seafhttp - [QSA,L]
SetEnvIf Authorization "(.*)" HTTP_AUTHORIZATION=$1
ProxyPreserveHost On
ProxyPass /
ProxyPassReverse /


port = 8083
web_token_expire_time = 3600
worker_threads = 15
max_upload_size = 16000
max_download_dir_size = 16000
max_indexing_threads = 4
fixed_block_size = 2

Any suggestions, thanks

I took a look at your configuration and that looks good.

Have you tried with another browser? Just to rule out client side problems?

I have tried on last versions:
Firefox (works good only with development panel activated),
Opera (doesn’t work, stay on "Packing… 67%),
Chrome (works good only with development panel activated),
Edge (doesn’t work, stay on "Packing… 0%),
IE11 (web interface doesn’t work after login, blank screen)

Also i have tried on another PC, the problem still have.

Can you try Seafile Server 8.0.7. The new release contains a fix for ZIP downloads.

Thanks for the information, I will try as soon as the free version appears, because I use the community version and do not have a download link for the pro version.

1 Like

I have tried Seafile Server 8.0.7 Community edition, the problem was not solved. Also i have tried disable apache on Virtual Machine and test config with Apache only on host machine, but nothing changes.

I noticed that when creating an archive, there are GET requests for each step of archiving, the result of each request adds percentages to the progress window. Maybe there is some way to change the number of requests - for example, increase the duration of each request?

It turns out that downloading ZIP works well on a small amount of files, because the next request does not have time to create.

I apologize for my English, this is not my native language.

I have tried to disable Apache on the host machine and use Seahub directly on port 8000.
The problem was solved! :grinning:
But I lost https and the pretty URL.
From this it follows that the problem is at the Apache level,

any ideas? :thinking:

Use Nginx?!?!

Everything works well with nginx. This is a good intermediate solution, thanks!

I hope the developers will see this problem and in the future they will correct the manual for Apache, or at least give some recommendations.

I had the same problem, migrating to nginx indeed solved the issue, until I fine tuned the server (which hosts other stuff) and set content expiry / cache control - which again broke the “zip download” functionality.
After a few trials and errors it turned out that “application/json” content shouldn’t be cached (the “download progress” likely uses json and needs to be refreshed in real-time).


  • turn off browser caching in the / location block: add_header Cache-Control "no-cache";
  • or, in the expiry map (which most people likely use): application/json off;

(I can’t test with apache now to confirm caching was also the issue back then)

Hope this helps !

EDIT: forgot to add that setting a strict referer policy like ‘no-referrer’ also breaks the progress popup (which then shows “permission denied” or something like that). So if a stricter policy was defined globally it should be relaxed for seafile - eg. back to 'strict-origin-when-cross-origin".

1 Like