Android 2.2.32 camera upload failed

The camera upload in the latest Android Seafile client (2.2.32) is not working anymore and the respective setting for choosing the folders to upload is missing.

Tested with Lineage 14.1 (Android 7.1) and 17.1 (Android 10), upgrade and fresh install.

Downgrade back to 2.2.31 solved the problem.

Can anyone confirm?

Yes, same here!

1 Like

@daniel.pan

I have this issue too. Furthermore, since the update, the seadroid app consumes an excessive amount of power, draining my phone battery very quickly, so had to revert to the previous version.
(android 10, MIUI 12)

The problem should have been solved in version 2.2.33.

1 Like

It’s partially solved. Upload is working again and you can set the folders to upload in the setup assistant. But the setting to reconfigure the folders in advanced settings is still missing in 2.2.33. Tested on Android 10 with a clean install.

i can confirm that 2.2.33 brought back the option to select the albums to sync.

however, the list offered seems to be incomplete. on my phoe, there’s the default “Camera” directory on the system device, which i can sync with seafile. but my photos are actually stored in a “Camera” directory on the SD card, which i am unable to find here. hence there’s still no syncing of photos for me. (forget about that, i found the directory, it was hidden in a huge collection of album covers, which android seems to interpret as photo albums with one image each…)

photo upload worked again.

but so far my videos have not been synced.

unfortunately, after two days i must confirm this: while photo sync is working again, videos are not being synced. i tried disabling an re-enabling both the video sync option and camera sync globally, but it didn’t help.

A classic. I’m guessing it’s hard to write tests for the camera upload components. It’s the only bug reappeared consistently with new updates.

2 Likes

Can you change your upload folders after the initial setup in advanced settings in 2.233?

unfortunately no, it’s only back in the configuration wizard when (re-)activating the camera upload feature.

Thanks for confirming. Then I guess it’s still a bug.

Solved with 2.2.34

unfortunately, on my android 10 phone the upgrade to 2.2.34 broke photo upload again. it hasn’t synced for eight days now.

I’m on 2.2.34, and photo and video uploads are not working. Library reports synced, but no files are uploaded to my server.

Reverted back to 2.2.31 and photo uploads are working again.

1 Like