Cannot install Seafile client

The installation of the Seafile client under Windows 10 tells me that the program seafile-applet.exe cannot be written under C:\program files\seafile\bin. I should check whether I have the required rights for this directory. And I do: I can create and delete files. It also doesn’t change anything if I explicitly authorize my user in the ACL, not just via a group.
I have installed this client so many times, but I have never had this problem. I have tried version 9.0.6, 9.0.5 and 8.0.10.

How could I solve that? An other thread says that I should use version 8.0.3 (Cannot install Desktop Syncing Clients on Windows 10 LTSC 2019).
Installationsfehler bei ZPNH

I now also have this problem on my own system. I wanted to update Seafile 9.0.3 to 9.0.6, but this stopped with the same error message. After aborting, the Seafile program folder is deleted. So now I have nothing at all.

I have used Seafile on this device for years, now I still have all my files, but I can no longer synchronize.

Have you tried to install with administrator permission?

This is weird. I’m working with a user who has administrative privileges, but I was not confronted with the UAC when starting the installation file seafile-9.0.6-en.msi. The program just starts. There is also no option on the file icon to choose Open as administrator or Install as administrator.

I opened a PowerShell as administrator, navigated to the installation file in the file system and hey presto, that’s how Seafile is installed.

2 Likes

Similar solve here. Ran the command prompt as administrator then ran the install package from there.