Client for Mac Crashes after every Laptop Suspend

Hello all - as the title indicates, every time I open my Mac Laptop after being suspended, the Seafile client (6.1.4) hangs and no longer works. It is similar to this issue, but there the discussion is about the Drive client crashing after a laptop suspends.

I have tried completely uninstalling and reinstalling the app, but the problem persists. This issue also existed on the prior client version.

Are there logs or other info I could provide to help troubleshoot?

Thank you.

High Sierra?
This causes a lot of trouble with hibernation since the upgrade to the latest OSX. Maybe this is related?

Do the other apps you have had open stay open after hibernation or were they started when switching the mac on?

Thank you for responding. Yes it is High Sierra. I haven’t had the problem with other apps not restoring that I recall but will pay more attention to see if others are having the problem as well. If there’s anything that I can help troubleshoot for seafile, please let me know.

Hi @myrison

Do you mean the GUI hangs, or the just syncing doesn’t work?

Thanks for the reply. The GUI hangs and the only way to recover it is to force quit the app and restart the app. It’ll then work fine again until the laptop suspends and then hangs again when it is restored.

Can you open the “console” app and find the crash report for seafile?

Hi Daniel - thanks again for keeping up with this thread. I appreciate it. Here are the related items I’m seeing in the logs after opening my laptop from sleep.

I looked in the console app and crash log folder: ~\Library\Logs\DiagnosticsReports and didn’t find a crash report, which made me realize I’m using the wrong terminology in this thread. It appears the app isn’t actually crashing. It’s hanging and the only way to fix it is to “force quit” which doesn’t create a crash log.

I do see some helpful info in the logs re: what might be causing it to hang. I’ve copied those images in below. Please let me know if I can send you anything else from the logs to help troubleshoot.

The second screenshot showing the sandbox: net.conceited (etc) lines is just a random sampling of the logs around the same time. I’m not sure if those messages are related to Seafile or not, but I see “mach” in both screenshots, so perhaps they are related.

Thanks again for the help.

Hi @daniel.pan. Just checking back to see if this info above was helpful or if there is other info I can provide you from my system ?

Thank you.

Same question here.

Hi,

Have you checked “System Reports” and “User Reports”?

By completely reinstall the app, have you deleted the folder “~/Seafile” and “~/.ccnet”?

Hi @daniel.pan. Thanks for the continued help. Below is more info.

From user reports, there is more info in the logs:

Example One:

Path:                  /Applications/Seafile Client.app/Contents/Resources/ccnet
       0x10d17f000 -        0x10d1a5ff7 +ccnet (???) <C2590CBA-27DB-3DDF-A4E2-515B94499A8A> /Applications/Seafile Client.app/Contents/Resources/ccnet
       0x10d1cb000 -        0x10d203ff7 +libevent-2.1.6.dylib (7.2) <951D3254-7801-3BD5-A54D-1624D91B2459> /Applications/Seafile Client.app/Contents/Frameworks/libevent-2.1.6.dylib
       0x10d219000 -        0x10d262fff +libssl.1.0.0.dylib (1) <4ED4ECDB-E8B1-33F8-A147-E50D5C93737B> /Applications/Seafile Client.app/Contents/Frameworks/libssl.1.0.0.dylib
       0x10d280000 -        0x10d42371f +libcrypto.1.0.0.dylib (1) <D7D3292B-9CAB-3CAE-85FE-088DEF16624E> /Applications/Seafile Client.app/Contents/Frameworks/libcrypto.1.0.0.dylib
       0x10d495000 -        0x10d55efff +libsqlite3.0.dylib (9.6) <B869339A-72FE-392E-A6B5-912FDDBFA390> /Applications/Seafile Client.app/Contents/Frameworks/libsqlite3.0.dylib
       0x10d573000 -        0x10d578fff +libsearpc.1.dylib (2.2) <035E26B8-846A-3D6C-81A2-344B8AFEDD26> /Applications/Seafile Client.app/Contents/Frameworks/libsearpc.1.dylib
       0x10d57f000 -        0x10d6acfff +libgio-2.0.0.dylib (5001.3) <58A586CA-465F-3A42-82BD-2053885EE43B> /Applications/Seafile Client.app/Contents/Frameworks/libgio-2.0.0.dylib
       0x10d6f6000 -        0x10d72ffff +libgobject-2.0.0.dylib (5001.3) <21B337CA-390C-32A4-A392-ED6BAE0F1B8D> /Applications/Seafile Client.app/Contents/Frameworks/libgobject-2.0.0.dylib
       0x10d746000 -        0x10d824ff7 +libglib-2.0.0.dylib (5001.3) <F3052A20-6A57-37BD-AC67-4B76C314411A> /Applications/Seafile Client.app/Contents/Frameworks/libglib-2.0.0.dylib
       0x10d84f000 -        0x10d858fff +libintl.8.dylib (10.5) <9041A290-68A1-3134-BDAA-3EF4DFFC8FBB> /Applications/Seafile Client.app/Contents/Frameworks/libintl.8.dylib
       0x10d85e000 -        0x10d867fff +libjansson.4.dylib (15) <C0CBC08C-9ACE-3F41-BA26-6BBF0EE8098A> /Applications/Seafile Client.app/Contents/Frameworks/libjansson.4.dylib
       0x10d874000 -        0x10d885fff +libz.1.dylib (1.2.11) <A22CD79F-ABFB-301C-ADF6-F733923EF1A5> /Applications/Seafile Client.app/Contents/Frameworks/libz.1.dylib
       0x10d88b000 -        0x10d983ff7 +libiconv.2.dylib (9) <84A8C8DD-CD0F-3B2D-9B85-C602256F00E6> /Applications/Seafile Client.app/Contents/Frameworks/libiconv.2.dylib
       0x10d990000 -        0x10d9f4fff +libpcre.1.dylib (4.8) <599510E7-23A3-3523-B701-FF4A25D7E094> /Applications/Seafile Client.app/Contents/Frameworks/libpcre.1.dylib
       0x10d9fb000 -        0x10da00fff +libffi.6.dylib (7.4) <3BB38592-BD64-3B31-9DB4-75CFBBD3EBE2> /Applications/Seafile Client.app/Contents/Frameworks/libffi.6.dylib
       0x10da0d000 -        0x10da10fff +libgmodule-2.0.0.dylib (5001.3) <6FBFDB8D-AAB4-31C2-AA8A-5AA3C14267F3> /Applications/Seafile Client.app/Contents/Frameworks/libgmodule-2.0.0.dylib

Example Two

Path:                  /Applications/Seafile Client.app/Contents/Resources/ccnet
       0x104f2e000 -        0x104f54ff7 +ccnet (???) <C2590CBA-27DB-3DDF-A4E2-515B94499A8A> /Applications/Seafile Client.app/Contents/Resources/ccnet
       0x104f7d000 -        0x104fb5ff7 +libevent-2.1.6.dylib (7.2) <951D3254-7801-3BD5-A54D-1624D91B2459> /Applications/Seafile Client.app/Contents/Frameworks/libevent-2.1.6.dylib
       0x104fcb000 -        0x105014fff +libssl.1.0.0.dylib (1) <4ED4ECDB-E8B1-33F8-A147-E50D5C93737B> /Applications/Seafile Client.app/Contents/Frameworks/libssl.1.0.0.dylib
       0x105036000 -        0x1051d971f +libcrypto.1.0.0.dylib (1) <D7D3292B-9CAB-3CAE-85FE-088DEF16624E> /Applications/Seafile Client.app/Contents/Frameworks/libcrypto.1.0.0.dylib
       0x10524e000 -        0x105317fff +libsqlite3.0.dylib (9.6) <B869339A-72FE-392E-A6B5-912FDDBFA390> /Applications/Seafile Client.app/Contents/Frameworks/libsqlite3.0.dylib
       0x10532e000 -        0x105333fff +libsearpc.1.dylib (2.2) <035E26B8-846A-3D6C-81A2-344B8AFEDD26> /Applications/Seafile Client.app/Contents/Frameworks/libsearpc.1.dylib
       0x10533e000 -        0x10546bfff +libgio-2.0.0.dylib (5001.3) <58A586CA-465F-3A42-82BD-2053885EE43B> /Applications/Seafile Client.app/Contents/Frameworks/libgio-2.0.0.dylib
       0x1054b0000 -        0x1054e9fff +libgobject-2.0.0.dylib (5001.3) <21B337CA-390C-32A4-A392-ED6BAE0F1B8D> /Applications/Seafile Client.app/Contents/Frameworks/libgobject-2.0.0.dylib
       0x1054ff000 -        0x1055ddff7 +libglib-2.0.0.dylib (5001.3) <F3052A20-6A57-37BD-AC67-4B76C314411A> /Applications/Seafile Client.app/Contents/Frameworks/libglib-2.0.0.dylib
       0x105607000 -        0x105610fff +libintl.8.dylib (10.5) <9041A290-68A1-3134-BDAA-3EF4DFFC8FBB> /Applications/Seafile Client.app/Contents/Frameworks/libintl.8.dylib
       0x10561d000 -        0x105626fff +libjansson.4.dylib (15) <C0CBC08C-9ACE-3F41-BA26-6BBF0EE8098A> /Applications/Seafile Client.app/Contents/Frameworks/libjansson.4.dylib
       0x105630000 -        0x105641fff +libz.1.dylib (1.2.11) <A22CD79F-ABFB-301C-ADF6-F733923EF1A5> /Applications/Seafile Client.app/Contents/Frameworks/libz.1.dylib
       0x10564c000 -        0x105744ff7 +libiconv.2.dylib (9) <84A8C8DD-CD0F-3B2D-9B85-C602256F00E6> /Applications/Seafile Client.app/Contents/Frameworks/libiconv.2.dylib
       0x10574f000 -        0x1057b3fff +libpcre.1.dylib (4.8) <599510E7-23A3-3523-B701-FF4A25D7E094> /Applications/Seafile Client.app/Contents/Frameworks/libpcre.1.dylib
       0x1057ba000 -        0x1057bffff +libffi.6.dylib (7.4) <3BB38592-BD64-3B31-9DB4-75CFBBD3EBE2> /Applications/Seafile Client.app/Contents/Frameworks/libffi.6.dylib
       0x1057c5000 -        0x1057c8fff +libgmodule-2.0.0.dylib (5001.3) <6FBFDB8D-AAB4-31C2-AA8A-5AA3C14267F3> /Applications/Seafile Client.app/Contents/Frameworks/libgmodule-2.0.0.dylib

From system reports, I only see information in the core_analytics logs, which I’m not sure is helpful, but just in case:

One Example:

{"message":{"activations":0,"activeTime":0,"activityPeriods":0,"appDescription":"com.seafile.seafile-client.findersync ||| 1.0 (1)","foreground":"NO","idleTimeouts":0,"launches":1,"powerTime":null,"processName":"Seafile FinderSync","uptime":9760},"name":"comappleosanalyticsappUsage","uuid":"4d7c9e4a-8c8c-4971-bce3-09d38d078849"}
{"message":{"activations":1,"activeTime":18,"activityPeriods":1,"appDescription":"com.seafile.seafile-client ||| 6.1.4 (6.1.4)","foreground":"YES","idleTimeouts":0,"launches":1,"powerTime":null,"processName":"seafile-applet","uptime":6937},"name":"comappleosanalyticsappUsage","uuid":"4d7c9e4a-8c8c-4971-bce3-09d38d078849"}

I’ll try a complete uninstall as well, but hopefully the log extracts above are helpful. Please let me know if they provide you any clues.

Just a quick update. I have now tried a complete uninstall as @daniel.pan described above, and the behavior has unfortunately not changed. (the application ‘hangs’ and requires to be ‘force quit’ after the laptop returns from suspend)

If there are other ideas as to how to troubleshoot, please let me know.

Gently bumping this to see if there is any hope/timeline for a future update to fix this.

I totally respect and appreciate that I’m just a free user of the product, but I have to think that the client dying after every laptop suspend/restore is an issue that affects a large number of users, so I wanted to bump this again to see if you’ve had a chance to look at what might be causing the problem.

Thank you!

1 Like

There is no detailed traceback in your crash report. And we can’t reproduce the problem with several of our Mac machines. So we don’t have enough information to work on the problem yet.

Thanks for the response Daniel. I’d be happy to provide a detailed traceback if you can please tell me how to produce one ? It happens 9/10 times I resume from standby so it shouldn’t be hard to get one once I know how.

I have the 2017 12” MacBook FYI.

Thanks for the quick response.

I’ve been using ~6.1 - current (6.1.5) with from Sierra to High Sierra (w/ Air 2015) and have not encountered any issues with the client. Are you using a Pro or Air @myrison(I presume Pro)? I can try a 2017 Pro in the morning to see if I can reproduce or get a similar result.

Neither actually. It’s the 12” MacBook (the ultra lite version). Thanks for the offer to help.

What cpu is in these models?

Mine has the i7 1.4GHZ 7th generation processor (Kaby Lake). Please let me know if you need more info.

Also, I just found this crash file in my user reports in the console. Maybe this will help…

It was quite long so I had to post on pastebin.