Client not syncing folders with hashes , e.g. "# Test #"

I am using Seafile Server 6.0.7 for Windows, nginx 1.13.6, MariaDB and Seafile Windows Client 6.1.1.

I have noticed that some folders and their contents are not syncing at all with the client. These seem to be folders that begin and start with a hash, e.g. “# Test #”. Maybe there are other peculirarities that I have not noticed. Filenames are not affected it seems.

I can create a folder with such a name in the web and it get’s synced by the client, but any content I add through the client does not get synced. I am not using a seafile-ignore exclusion.

Is this a bug in the involved softwares or a configuration error?

This is not problem of seafile, but Windows. In linux you can create folders with some special characters and Windows see them(on flash drive for example) but cannot access them right. So leave this characters please a it will work.

FYI look here:

1 Like

Thank you for the reply, but I am a bit confused: what does Sharepoint have to do with this (the link that you provided)? Maybe you can’t use # in a Sharepoint folder, but I am definetly not using that Crapware. You can use # in foldernames in Windows OS filesystem without any restrictions, no matter on internal or external drives.

This is a problem of Seafile. I have since asked a friend running Seafile Pro to test it with Mac and Unix clients, and exactly the same problem. Try it for yourself and create the following folders on a client machine to sync with the client software:

  • #test syncs
  • test# sync
  • #test# does not sync
  • #test#% sync
  • test#% syncs

The problem is with # at the beginning and the end. If another character follows # it works as well.

1 Like

I can confirm this problem. I run Seafile Server 6.1.1 on Debian and the Client on Ubuntu 17.10.

1 Like

Anyone? Could somebody please confirm whether this is a bug?

I can confirm that a file #test# is not being synced. I think it is due to an internal ignore list. But it should be synced.

Seafile support and developers, could you please comment on this? It’s a bit disconcerting for production use that some files are not synced. And I am concerned that other file name patterns that I have not spotted yet are also problematic.

@daniel.pan

This is a designed behaviour. Some name patterns that match temporary files generated by programs like Word, Excel are ignored.

@daniel.pan But shoudn’t the folder then sync correctly when I check “Enable sync temporary files of MSOffice/Libre”? This option has no effect on folder syncing with a name such as "# Test # ".

That only syncs the temporary files of that software…

@daniel.pan maybe you should add it to the client documentation which files are not being synchronized.

1 Like

And again I’d like to refere to this simple solution for this: Path and Windows reserved characters

Just prevent us from being able to enter these characters in WebUI or Windows ClientBrowser in the first place. The problems arising from this are very annoying

2 Likes