Empty shared folders

Hello - I have a problem with the shared folders
I’m using Seafile Drive Client 1.0.10 on Windows 10 and have a setup of Seafile Server 7.0.5 (Community Edition) for Raspberry Pi. In SeaDrive I can see only my owned libraries but shared libraries and directories from other users to me is missing. B.t.w. - I had the same problems with previous Seafile Server 6.x versions before.

I already tried some workarounds found here in the seafile forum, such from @FabienP
Moreover I created new user accounts and new libraries and shared them - without success.

I tested the same Drive Client on the same machine with an other account hosted on a Seafile Server 6.3.13 (Pro) and experienced no problems. All shared libraries showed up and were accessible.

Thus, the problems seems to occur in connection of Seafile Drive Client with Seafile Server CE (for Raspberry Pi). Obviously such problems were already apparent in the past with @Landrius

Any help on this is welcome.

Hi Hermes73,
welcome to the Seafile Community Forum!
I cannot comment on your post. The last time I had a RasPi in my hands was 2-3 years ago.
But let’s see what the RasPi aficionados in this forum have to say about your problem.

Thanks for your friendly welcome!
Meanwhile I installed the current Seafile Drive Client (1.0.9) for Linux on my Ubuntu 18.02 LTS machine. I experienced the same problems - all shared folders remained empty.
@FabienP, @Landrius: Thus, it really seems to be a problem of Seafile Server Software (version 7.0.5, CE) for Raspberry Pi (arm). I will post my findings accordingly in the seafile server section of the forum, too.

Update : I installed and tried out Seafile Server 7.0.5 (Community Edition) for AMD64 on Ubuntu 18.03. It worked like a charm, all shared folders were displayed with its contents and were accessible.

Therefore I see two possible causes:

  1. It’s a problem soleley related to the Raspberry Pi Version.
  2. It’s a problem related to database structure and contents and/ or seafile’s filesystem, maybe due to several version upgrades I did, beginning from early version 6 to now version 7.0.5.

Since it doesn’t seem to be a problem of seadrive, I will continue the discussion in my seafile server thread: https://forum.seafile.com/t/empty-shared-folders-in-connection-with-seadrive/10754

Hi Hermes,
glad to hear that you could narrow down the problem.
Could you mark this thread as solved/closed because it is not a SeaDrive problem.
Ralf