Empty Shared Folders in connection with seadrive

Hello - I have a problem with the shared folders
I’m using Seafile Drive Client 1.0.10 on Windows 10 and have a setup of Seafile Server 7.0.5 (Community Edition) for Raspberry Pi. In SeaDrive I can see only my owned libraries but shared libraries and directories from other users to me is missing. B.t.w. - I had the same problems with previous Seafile Server 6.x versions before.

I already tried some workarounds found here in the seafile forum, such from @FabienP
Moreover I created new user accounts and new libraries and shared them - without success.

I tested the same Drive Client on the same machine with an other account hosted on a Seafile Server 6.3.13 (Pro) and experienced no problems. All shared libraries showed up and were accessible.

The problems seem to occur in connection of Seafile Drive Client with Seafile Server CE (for Raspberry Pi). Obviously such problems were already apparent in the past with @Landrius

Meanwhile I installed the current Seafile Drive Client (1.0.9) for Linux on my Ubuntu 18.02 LTS machine. I experienced the same problems - all shared folders remained empty.
Thus, it really seems to be a problem of Seafile Server Software (version 7.0.5, CE) for Raspberry Pi (arm).

Any helpful advice is welcome.

Update: I installed and tried out Seafile Server 7.0.5 (Community Edition) for AMD64 on Ubuntu 18.03. It worked like a charm, all shared folders were displayed with its contents and were accessible.

Therefore I see two possible causes:

  1. It’s a problem soleley related to the Raspberry Pi Version.
  2. It’s a problem related to database structure and contents and/ or seafile’s filesystem, maybe due to several version upgrades I did, beginning from early version 6 to now version 7.0.5.

Does anybody have ideas or insights on that?

@hermes73 I’m having the same behaviour -installed SeaDrive Client 1.0.10. No clues why this happens. At this momment I don’t have any time to analyze. Do you get some error on logfiles?

@jobenvil I didn’t found anything suspicious in the log files - no errors so far. Except in seahub.log, where I found an error already reported in the forum, concerning group shares: Error in seahub when accessing group shares

Maybe this is related? Do you have any suggestions for me to look for in the logs (in which ones)? Or how to get more verbose logfiles?
Thank you for your help!

Hi there,
meanwhile I did some further testing. I set up a new seafile server on my arm-machine from the scratch, with newly created databases, users and content for testing. I wanted to exclude possible ‘old’ problems from a longrunnig system, which was updated several times. Still the problem with all kind of shared folders remain.
@jobenvil Thus, I am now able to narrow down the problem to the arm version of seafile server software. Existing databases and old data from previous versions are not the problem.

Does anybody already have any ideas? Or does anybody have no such problems in a similar setting?