Error:Seahub failed to start. no specific error 8.0.7

I have just downloaded seafile-server-8.0.7 and installed it on Lubuntu 20.04.3 LTS, 64-bit.
The did its job nicely, and seafile-controller and seaf-server are running with sensible-looking arguments.

I ran seahub start but saw this barebones error:

Starting seahub at port 8000 ...
Error:Seahub failed to start.
Please try to run "./ start" again

I ran the command again with the same result, and looked in the logfile, but nothing there.

Considering how well done the installation script is, I was surprised there wasn’t any more information in the error message.

What more information could I provide to help you understand what has gone wrong?


Hi Jim,

welcome to the Seafile Community Forum!

When Seahub fails to start, it is usually a connection problem with the database.

Here are two options:
a.) Please make sure that you have all required packages installed. Sometimes the packages have different names in other distributions. I’d think that Lubuntu uses the same repositories and hence the name package names, but I am not familiar with Lubuntu.

In many cases, you can also run ./ start-fastcgi. This may give you a more verbose error message. (fastcgi is no longer supported, hence Seahub wil surely fail to start. But this does not mattter. All you are after is the error message that may give you a hint.)

b.) You can use Seafile with Docker. Then all these dependency topics go away.

Thanks, rdb, for the suggestion. With start-fastcgi it said it couldn’t find “captcha”.
So I did a recursive grep through all the files extracted from the installation file and found the error message twice in I added a bit to each error message and ran the program again with the start argument. This time I saw the message
Error:Seahub failed to start – pgrep failed with seahub.wsgi:application.
I think it would be very helpful if a programmer could work out what those two errors represent and add appropriate details to the error messages.
And saying to run the program again is not helpful – the problem has to be resolved first :slight_smile:

Does this previous post help at all?

pip3 install --timeout=3600 Pillow pylibmc captcha jinja2 sqlalchemy django-pylibmc django-simple-captcha python3-ldap

Make sure that captcha for Pyhton 3 is installed.