Fresh seafile server on pi returns internal server error

So after trying to setup a seafile server on my raspberry pi 3 it keeps returning a internal server error.
I followed the “seafile manual using mysql” closely.
Steps to reproduce:

  1. Prepare MySQL:

sudo apt-get install mysql-server php5-mysql
mysql -p -u root
create database ccnet-db character set = ‘utf8’;
create database seafile-db character set = ‘utf8’;
create database seahub-db character set = ‘utf8’;
create user ‘seafile’@‘localhost’ identified by ‘seafile’;
GRANT ALL PRIVILEGES ON ccnet-db.* to seafile@localhost;
GRANT ALL PRIVILEGES ON seafile-db.* to seafile@localhost;
GRANT ALL PRIVILEGES ON seahub-db.* to seafile@localhost;

  1. Prepare Seafile:

sudo apt-get install python2.7 libpython2.7 python-setuptools python-imaging python-ldap python-mysqldb python-memcache python-urllib3
sudo adduser seafile --disabled-login
sudo su - seafile

  1. Install Seafile:

tar -xzf seafile-server_*
mkdir installed
mv seafile-server_* installed
cd seafile-server-*/
on prompt servername: seafile
on prompt ip/domain:
on prompt volume for seafile data: /mnt/bib/seafile/data
on prompt port: default
on prompt seafile database type: 2 (use existing)
on prompt mysql host: default
on prompt mysql port: default
on prompt mysql user: seafile
on prompt mysql user password: seafile
on prompt database names: as above (3x)
> successful

  1. Starting seafile server:

./ start
> successful
./ start
on prompt email:
on prompt password: example (2x)
> successful

  1. Connecting to Seafile web interface:
> 500 Internal Server error

cat …/logs/* returns

[08/31/17 19:58:34] …/common/session.c(132): using config file /home/seafile/conf/ccnet.conf
[08/31/17 19:58:34] …/common/session.c(484): Listen on /home/seafile/ccnet/ccnet.sock for local clients
[08/31/17 19:58:34] …/common/session.c(290): Update pubinfo file
[08/31/17 19:58:35] …/common/session.c(398): Accepted a local client
[08/31/17 19:58:35] …/common/session.c(398): Accepted a local client
[08/31/17 19:58:35] …/common/session.c(398): Accepted a local client
[08/31/17 19:58:35] …/common/session.c(398): Accepted a local client
[08/31/17 19:58:54] …/common/session.c(398): Accepted a local client
[08/31/17 19:59:14] …/common/peer.c(943): Local peer down
[08/31/17 19:58:34] seafile-controller.c(154): starting ccnet-server …
[08/31/17 19:58:34] seafile-controller.c(73): spawn_process: ccnet-server -F /home/seafile/conf -c /home/seafile/ccnet -f /home/seafile/logs/ccnet.log -d -P /home/seafile/pids/
[08/31/17 19:58:34] seafile-controller.c(88): spawned ccnet-server, pid 7780
[08/31/17 19:58:35] seafile-controller.c(555): ccnet daemon connected.
[08/31/17 19:58:35] seafile-controller.c(186): starting seaf-server …
[08/31/17 19:58:35] seafile-controller.c(73): spawn_process: seaf-server -F /home/seafile/conf -c /home/seafile/ccnet -d /mnt/bib/seafile/data -l /home/seafile/logs/seafile.log -P /home/seafile/pids/
[08/31/17 19:58:35] seafile-controller.c(88): spawned seaf-server, pid 7785
[08/31/17 19:58:35] seafile-controller.c(528): seafdav not enabled.
[08/31/2017 07:58:36 PM] …/common/mq-mgr.c(54): [mq client] mq cilent is started

After enabling of Webdav in seafdav.conf the WebDAV Server @ is reachable. This still doesn’t solve the Web interface problem.
Any recommended solutions?

Edit: Additional packages mentioned in 6.1.2 & 6.1.1 releases are already installed.

1 Like

Same problem here, only while using sqlite.

Have you had any success so far?

I just solved it by installing the requests and pyyaml Python modules, which were missing on my machine. Apparently everything is working now.

This does not solve the problem here. The problem seems to be independent from mysql / sqlite as it appears in both cases.

Internal Service Error is difficult to debug. Try first checking your python modules with the indicated in this thread

I checked it multiple times - here is a greped list of my python modules:

dh-python; idle-python2.7; idle-python3.4; libpython-all-dbg:armhf; libpython-all-dev:armhf; libpython-dbg:armhf; libpython-dev:armhf; libpython-stdlib:armhf; libpython2.7:armhf; libpython2.7-dbg:armhf; libpython2.7-dev:armhf; libpython2.7-minimal:armhf; libpython2.7-stdlib:armhf; libpython3-all-dbg:armhf; libpython3-all-dev:armhf; libpython3-dbg:armhf; libpython3-dev:armhf; libpython3-stdlib:armhf; libpython3.4:armhf; libpython3.4-dbg:armhf; libpython3.4-dev:armhf; libpython3.4-minimal:armhf; libpython3.4-stdlib:armhf; python; python-all; python-all-dbg; python-all-dev; python-apt; python-apt-common; python-blinker; python-chardet; python-colorama; python-crypto; python-dateutil; python-dbg; python-dbus; python-dbus-dev; python-dev; python-distlib; python-dnspython; python-flask; python-gi; python-gobject-2; python-gpiozero; python-html5lib; python-imaging; python-itsdangerous; python-jinja2; python-ldap; python-ldb; python-markupsafe; python-memcache; python-minecraftpi; python-minimal; python-mysqldb; python-ndg-httpsclient; python-nose; python-ntdb; python-numpy; python-openssl; python-picamera; python-picraft; python-pifacecommon; python-pifacedigitalio; python-pigpio; python-pil:armhf; python-pip; python-pkg-resources; python-pyasn1; python-pyinotify; python-requests; python-rpi.gpio; python-rtimulib; python-samba; python-sense-emu; python-sense-hat; python-serial; python-setuptools; python-simplejson; python-six; python-smbus; python-spidev; python-support; python-talloc; python-tdb; python-tk; python-tk-dbg; python-twython; python-urllib3; python-werkzeug; python-wheel; python-yaml; python2.7; python2.7-dbg; python2.7-dev; python2.7-minimal; python3; python3-all; python3-all-dbg; python3-all-dev; python3-chardet; python3-codebug-i2c-tether; python3-codebug-tether; python3-colorama; python3-dbg; python3-dev; python3-distlib; python3-flask; python3-gi; python3-gpiozero; python3-html5lib; python3-itsdangerous; python3-jinja2; python3-markupsafe; python3-minecraftpi; python3-minimal; python3-nose; python3-numpy; python3-openssl; python3-pgzero; python3-picamera; python3-picraft; python3-pifacecommon; python3-pifacedigital-scratch-handler; python3-pifacedigitalio; python3-pigpio; python3-pil:armhf; python3-pip; python3-pkg-resources; python3-pygame; python3-pyinotify; python3-requests; python3-rpi.gpio; python3-rtimulib; python3-sense-emu; python3-sense-hat; python3-serial; python3-setuptools; python3-six; python3-smbus; python3-spidev; python3-tk; python3-tk-dbg; python3-twython; python3-urllib3; python3-werkzeug; python3-wheel; python3.4; python3.4-dbg; python3.4-dev; python3.4-minimal;

and here a list of my pip:

beautifulsoup4 (4.6.0)
blinker (1.3)
certifi (2017.4.17)
chardet (3.0.4)
colorama (0.3.2)
decorator (4.0.11)
Django (1.11.2)
django-modelcluster (3.1)
django-taggit (0.22.1)
django-treebeard (4.1.1)
djangorestframework (3.6.3)
dnspython (1.12.0)
Flask (0.10.1)
gpiozero (1.4.0)
html5lib (0.999)
idna (2.5)
imageio (2.1.2)
itsdangerous (0.24)
Jinja2 (2.7.3)
MarkupSafe (0.23)
mcpi (0.1.1)
moviepy (
MySQL-python (1.2.3)
ndg-httpsclient (0.3.2)
nose (1.3.4)
numpy (1.8.2)
olefile (0.44)
picamera (1.13)
picraft (1.0)
pifacecommon (4.2.1)
pifacedigitalio (3.1.0)
pigpio (1.35)
Pillow (4.2.1)
pip (9.0.1)
pyasn1 (0.1.7)
pycrypto (2.6.1)
pygobject (3.14.0)
pyinotify (0.9.4)
pyOpenSSL (0.13.1)
pyserial (2.6)
python-apt (
python-dateutil (2.2)
python-ldap (2.4.10)
python-memcached (1.53)
pytz (2017.2)
PyYAML (3.11)
requests (2.17.3)
RPi.GPIO (0.6.3)
RTIMULib (7.2.1)
sense-emu (1.0)
sense-hat (2.2.0)
setuptools (5.5.1)
simplejson (3.6.5)
six (1.8.0)
smbus (1.1)
spidev (3.0)
tqdm (4.11.2)
twython (3.1.2)
Unidecode (0.4.20)
urllib3 (1.21.1)
Werkzeug (0.9.6)
wheel (0.24.0)
Willow (0.4)

A clean reinstall of python solved the problem.

1 Like