Installed Seafile, Backend setup great, but browser only shows a blank screen / "page can’t be found"!

I installed Seafile 6.3.2 in a custom app on Webfaction listening on a port. I followed the instructions and started seahub and seafile, then went to the domain and got a blank white screen on FireFox, and a “page can’t be found” error in Chromium. I had the same problem with 6.2.5. is a blank screen on firefox and a “Page cannot be found” error in Chromium
SAME_DOMAIN:8000 says “Unable to connect”

In the setup I gave it the port of the custom app. In a previous installation I left the default port, and in that case I got an error in both browsers instead of a blank screen (server not found or problem loading page, I don’t remember). So I’m sure it was right for me to give it the port of the custom app.

It seems like Seafile’s backend WAS working fine. It populated the databases and took my admin info in the terminal. But nothing’s delivering to the front end.


The access log is empty. The error log is full of stuff like this:

[ERROR] Can’t connect to (‘’, 8000)

Why is it connecting to ?

I tried to run ./ start-fastcgi and got an error:

Unknown command: ‘runfcgi’

and the server won’t start.


I got a new kind of error with the same result. There was something else listening on ‘, 8000’ and I shut it down. Now I get this error:

[2018-08-05 04:49:32 +0000] [10427] [INFO] Starting gunicorn 19.8.1
[2018-08-05 04:49:32 +0000] [10427] [INFO] Listening at: (10427)
[2018-08-05 04:49:32 +0000] [10427] [INFO] Using worker: sync
[2018-08-05 04:49:32 +0000] [10437] [INFO] Booting worker with pid: 10437

And my browser gives the exact same errors as before.

How can I find out what I’ve done wrong?

Fastcgi Support has been dropped. You need to migrate to build in webserver and forward requests as http from your proxy

1 Like

I don’t actually need fastcgi. I just read somewhere that you get more error reports somehow by doing that.

In fact what you are trying to do is running Seafile in fastcgi mode.

Thanks very much for the answers.

I followed the instructions in the manual. What should I be doing differently?

How do I “migrate to build in webserver” ? I am using a WebFaction webserver on which I run Rails, Flask, Django, PHP apps (that I wrote) with no problems. But I don’t know what you mean by “migrate to build in webserver.”

How do I “forward requests as http from my proxy?” And will that actually solve the problems I listed above?

How do I NOT use fastcgi? I only tried that command a couple times. All the other times I just did:

./ start

without the ‘-fastcgi’ affixed to the end.

So how do I NOT use fastcgi?

1 Like

With start-fastcgi you use fastcgi. Without you do not.

Okay, then fastcgi has absolutely nothing to do with my problem, because I almost never started in fastcgi.

This is what you said you would have done …

Looks like you try to let it run on port 8000. Do you have a firewall that blocks inbound connections to port 8000?

1 Like

Every other time I just ran:

./ start

and still got the same error. Also, it says “port 8000” no matter which port I specify, which seems weird. Shouldn’t it be listening to the port of my app, which I specified in the setup? Or is this something different?

Seafile by default runs on Port 8000, which is not SSL secured and therefore not recommended. This is the reason why you use nginx as a reverse proxy, so nginx is responsible for SSL and other features and opens Port 443 (for example), which you can use to connect to Seafile. Nginx connects on Port 8000 to localhost, where Seafile is running.

See and

This means the port will listen on all interfaces that are available. You can bind it to just listen on one IP (for security reasons for example).