Only first 100 folders being displayed in Firefox


#21

@korry remove your mail from output for your private.

@daniel.pan Here down is formated output. I think that this is bug, but I have on one from nine same issue without XHR request (on private server). can you look at it?

[
  {
     "permission":"rw",
     "encrypted":false,
     "mtime_relative":"56 minutes ago",
     "mtime":1512634131,
     "owner":"user@test.com",
     "root":"",
     "id":"2de93842-7bdb-4dcd-a2f9-a00a99775e55",
     "size":650083805,
     "name":"Books",
     "type":"repo",
     "virtual":false,
     "version":1,
     "head_commit_id":"a349d333b2b6b01a92e7fd0823243e9176ac26ef",
     "size_formatted":"620.0\u00a0MB"
  },
  {
     "permission":"rw",
     "encrypted":false,
     "mtime_relative":"2017-08-28",
     "mtime":1503897358,
     "owner":"user@test.com",
     "root":"",
     "id":"9ccf9e9d-9b37-421b-a9c1-8159c4283664",
     "size":556583,
     "name":"Pub",
     "type":"repo",
     "virtual":false,
     "version":1,
     "head_commit_id":"1573fafe5fba60b1b6044e4bc01c973cd29a089b",
     "size_formatted":"543.5\u00a0KB"
  },
  {
     "permission":"rw",
     "encrypted":false,
     "mtime_relative":"2016-10-23",
     "mtime":1477201756,
     "owner":"user@test.com",
     "root":"",
     "id":"40ce2896-9aa2-4e63-8368-4f3c20bf6542",
     "size":201539,
     "name":"Moscito",
     "type":"repo",
     "virtual":false,
     "version":1,
     "head_commit_id":"75dfb434afe1330177d11c9bcba8eeee0669fa70",
     "size_formatted":"196.8\u00a0KB"
  }
]

#22

I checked the request on the seafile demo site. All Items (i tested with 400 now) are loaded with one request when the folder is opened. There is no reloading of items, just an extending of the displayed list.


#23

Thanks Garfield, I assume you have not used Chrome, right?
Anyway, only first 100 items are displayed for me and it is reproducible. I think it is a bug and kindly ask the devs to have a look.


#24

As I said. Wi have same error in company on only one PC. Rest working good


#25

Can you please check with your brower if you have problems with the seafile demo site, too? (it’s telling it’s v6.2.1)
If it’s working on this page, it’s either a bug in your (hosters?) specific version or a server misconfiguration. If it is not working, i would tell it’s a problem with the browser.
Perhabs you can even check with the not working site what the servers answer looks like when opening a folder with lots of files. On the seafile demo site the json-result has a property “dirent_list” with each and every item within the directory. Is it the same on your system?


#26

Just tested with Firefox on Windows on demo.seafile.com and unfortunately it did not work and only first 100 files got listed.
Can check with Firefox on Ubuntu on Saturday and post the result.
Just to be sure I do the things correctly, I open the folder with 100+ files, get first 100 listed, then click on the arrow down on the scroll bar and the expected behaviour would be to see the rest (which does not happen for me), right?


#27

Yes, thats the behaviour it should have. It shows some more items when you reach the end of the page.
Can you please check if there are any errors in the browser console?


#28

I was also facing the same issue… See the browser console


#29

This issue are also when you trying to watch pictures in the “big thumbnail mode” I don’t remember the name for it, it’s not the list mode it’s the other one.


#30

Since the last browser updates it doesn’t work for me anymore.
@daniel.pan do you know why it’s not working?


#31

Hmm, funny thing is that it’s now working again with my seafile installation (updated ubuntu from 17.04 to 17.10). What’s going on there?


#32

It’s related with CSP. Your CSP setup bloking some frames.

We have still same issue. After update Chrome and Win 10 to Fall Creators update issue persists. We steal don’t have any request called after scroll to bottom and no JS error. I think there’s some random issue with cache.


#33

As scrolled link effect is creating a problem in firefox, i am planning to load the complete page at once, can someone help me as to where to modify the code.


#34

I’m on Linux Mint 18.3 with Firefox 57.0.4 (Seafile hosted in Yoursecurecloud) and I don’t have this problem, neither for files nor for folders. When I get to the bottom (every 100 items) the rest gest loaded.


#35

The problem is with firefox in mac.


#36

I found that on a windows 10 Laptop there is one folder in which the bug occurs, and in another folder everything is fine. And then there is one folder, where the bug occurs only in the details view, not in the tiles view…
On another PC the folder not working on one laptop is working.
So what is going on there? :o


#37

It’s the same for firefox in Windows and Ubuntu also.


#38

I can confirm that this problem occurs with both Firefox 57.0.4 and Chrome 63.0.3239.132 on Windows 10 Pro (64bit) Creators Update (updated). It works fine on Opera 50.0.2762.58 and Microsoft Edge 40.15063.674.0 on the same OS.


#39

I solved this for our computer. It caused by ZOOM page for us. User accidentally zoom page to 110% so you cannot see big difference(only little magnify icon in URL bar). So I hit CTRL+0 to reset zoom into 100% and loading start working. SO please try to check you zoom. Maybe that can be your problem too.


#40

Looks like this can be helpful for the devs.

A working zoom is mandatory.