Seadrive on raspberry Pi

I’m aware that it’s possible to compile seafile for aarch64, but that is not possible for seadrive since it is closed source. It does not make sense for me to install the sync client on this device since it does not have a lot of free space to throw around. Are there any plans on publishing the code for seadrive? If not, would it be possible to add aarch64 as a compilation target on the deb repo?

bump bump bump

What’s the reason for not using the WebDAV integration of Seafile?

Also, have a look at Rclone. Rclone supports Seafile and might be helpful for your use case.

At that point I might as well use the seafile sync client. As for WebDAV, I have it disabled on the server since seadrive exists, last time I had it enabled it bypassed 2fa.

Not sure what you mean. The sync client doesn’t allow mounting as a drive. The other options do.

From what I gathered reading Rclone’s implementation of the seafile backend, it uses the API hosted by seahub for almost all transactions. Encrypted libraries are decrypted on the server (what is even the point) and conflicts are resolved by Rclone itself. One if not the strong advantage seafile has is how accurately it detects file conflicts, I have not had once false positive while using it, replacing that with what’s basically a generic cloud provider would not be ideal.

Thanks for the suggestion though, I’ll probably end up using it if the devs don’t open source the seadrive client or build it for aarch64.

There are hopes on getting seadrive running on aarch64

Has anyone seadrive running on a raspberry Pi?
I just compiled it by myself like described here but when i try to run it like described i get a Errormessage:

pi@XXX:~ $ seadrive -c ~/seadrive.conf -f -d ~/.seadrive/data/ -l ~/.seadrive/logs/seadrive.log virtual-drive-dir
seadrive: error while loading shared libraries: cannot open shared object file: No such file or directory

But libsearpc seems to be installed succesfull:

pi@XXX:/usr/local/lib $ ls
libccnet.a libsearpc.a python2.7 python3.5 libevhtp.a pkgconfig stGdK0Ux

Has anyone an idea what went wrong?

I got the same problem. Did you solve it?


not sure if you solved the problem already, but I found this topic because I had the same problem.

For me it was enough to install the package libsearpc-dev

sudo apt install -y libsearpc-dev

Sorry for the late reply, but here is how I managed to compile seadrive for the RPI, the build process runs in a docker contianer to be able to isolate any issues. This worked at the time of creating the gist, but I can’t guarantee no troubleshooting will be required to get it to compile on a modern version of raspberry pi os

Also there is no official Raspbian image, so I needed to use this to import the rootfs into a docker image. Same disclaimer as before applies

Hope this helps, if there’s any problems open an issue or comment on the gists.