Seafile community edition 11.0.3 and SeaDoc 0.4 are now ready!

We are glad to announce that Seafile community edition 11.0.3 is ready. It is a stable release.

In Seafile 11.0.3, we continue work on improving the UI:

  • Different favicon for different file type pages
  • Other UI improvements and fixes

The integrated SeaDoc is also upgraded to version 0.4 (beta). The main changes include:

  • UI improvement for tables
  • A new callout element
  • Ui improvement for comments feature
  • UI improvement of the revision feature

Let’s look at the details below.

Seafile 11.0.3

Seafile 11.0.3 mainly includes some improvements and fixes on the UI.

Use different favicon on preview pages for different file types

This gives users better distinguish for different file preview pages.


Improved the UI of the error dialog when zip download failed


Improved the UI for editing sharing permission, user roles and other places

Originally, you needed to click the edit button first and enter the edit mode before you could make changes. Now, you can make direct modifications by clicking on the dropdown arrow.


Improved the UI for document conversion


Improved the avatar UI and removed the dropdown triangle next to the avatar

The dropdown triangle next to the avatar has been removed.


SeaDoc 0.4

Improvements in table functionality

  1. You can now select a template when creating a table.


  1. Tables now support cell merging.

Improvements in comment functionality

  1. Comments now display the corresponding paragraph.


Adding drag-and-drop functionality

You can now move an element by dragging it using the side button.


Adding callout elements

You can add callout elements in the document. The callout element has various highlight background colors. This type of elements can be used to display some information that readers need to pay attention to in the document.


After the revision is published, the page displays a ‘published’ indicator


Other changes and fixes

  • Input "1. " will now create ordered list
  • UI fixes for check list
  • Support uploading multiple images from local
  • Fixed some issues in changing an image’s display mode to block

Is the download page up-to-date yet for 11.0.3b?

Thanks for the notification. It has been updated now.

There is an error in SQL-Upgrade Script “seahub.sql” on line:

ALTER TABLE org_saml_config CHANGE domain domain varchar(255) DEFAULT NULL;

The coloum “domain” does not exist, because in seafile upgrade script from version 10.0.0 the table was created like this:

CREATE TABLE IF NOT EXISTS org_saml_config (
org_id int(11) NOT NULL,
metadata_url longtext NOT NULL,
UNIQUE KEY org_id (org_id)

Sorry for causing trouble to you. The column ‘domain’ was added in version 11.0.1. You can refer to the following steps to solve upgrade problems:

  1. Manually add the column in the database,
    ADD COLUMN IF NOT EXISTS domain varchar(255) DEFAULT NULL;
    ALTER TABLE org_saml_config ADD UNIQUE INDEX IF NOT EXISTS (domain);
  2. Manually execute the upgrade script,
  3. Restart seafile.

First of all, thanks for your hard work.
Secondly, will Seafile Pro 11 be released soon? I don’t see the new file on the Pro download page.


Pro edition will be released in January.

Hi Daniel,
Good job. Thank you for this update.


This looks a great new version, two issues I’ve encountered with the upgrade (in addition to the missing DB column noted above).

  1. On Debian Bookworm, I also had to install libsasl2-dev so that python-ldap could be built.
  2. The call to in upgrade/ doesn’t handle spaces in passwords, and by the look things a whole stack of other special characters. You need to put quote marks round the variables.

Kind regards,

1 Like

i just installed seafile 11.0.3 (compiled from source using the ARM script) using ./ auto ... but afterwards ./ start fails with an error hinting to the pro version:

awk: fatal: cannot open file <install path>/seafile-server-11.0.3/pro/python/seafevents/' for reading: No such file or directory

any idea how to fix this?

We will look into the issue in the next week.

thanks! i suspect the build didn’t work properly, perhaps the script needs to be adjusted for v11 builds (missing flags?)? i just checked and the 10.0.1 build using the same script runs without errors.

however, i noticed that after i called ./ auto with the --seafile-dir flag poiting to a different directoy caused the configuration to either be incomplete or buggy, as seafile wouldn’t start because it didn’t find any data directory. i manually created seafile-data in the installation directory to get rid of this, but i assume --seafile-dir should be used to configure a different location?

It requires some edit to the build script indeed (and some to seahub’s too).

But you can can try something like this:

cd seafile-server-11.0.3
mkdir -p pro/python
cp seahub/scripts/ pro
cd pro/python
git clone --branch v11.0.3-server --depth 1

Don’t remember exactly but then you may need to create a seafevents.conf file in your conf directory:

type = mysql
host =
port = 3306
username = seafile
password = secret
name = seahub_db
enabled = false
interval = 30m
enabled = false
1 Like

I successfully compiled seafile-server-11.0.3-bookworm-armv7l.tar.gz (using Raspberry Pi - Seafile Admin Manual - with a lot of fixes due to outdated python-libraries). When invoking ./ start <PORT> I had the same error as @m.eik :

which could be solved with the help of the previous post from Barolo

But now there is still this error remaining when starting ./ start <PORT>:

Error: module 'inspect' has no attribute 'getargspec'
Error:Seahub failed to start.

which I can’t debug any further due to my limited knowledge.
Any help would be appreciated.

EDIT (13.01.2024): Apparently inspect.getargspec has been removed with Python 3.11. Though I am running Debian Bookworm with Python 3.11.2 I am not entirely sure whether that is really the problem. In any case I have no clue how to solve this…

thanks for your remarks!

unfortunately, this didn’t really resolve the issues. i noticed that there is already a pro/python/seafevents directory (so git refuses to overwrite). i don’t get any error messeges except Error:Seahub failed to start. Please try to run "./ start" againlog/seahub.log doesn’t show anything. this makes it hard to debug :confused:

does seafevents use the same database as seahub, as your example suggests? the config template in seafevents names the database seafevents.

@daniel.pan do you have any advice how to manually get this working using the supposedly outdated build script?

ok, when i set daemon = False in conf/, i got this error:

Starting seahub at port 8000 ...
Traceback (most recent call last):
  File "/usr/local/lib/python3.10/dist-packages/MySQLdb/", line 18, in <module>
    from . import _mysql
ImportError: cannot open shared object file: No such file or directory

installing the python package mariadb and subsequently rebuilding mysqlclient solved this issue. alternatively, installing libmysqlclient21 via apt also proved to be successful, but not having MySQL packages around felt like a more elegant solution.

We have updated the instruction for building Seafile community edition on Raspberry Pi or other platforms: Raspberry Pi - Seafile Admin Manual

On the other hand, Seafile community edition includes a docker image that can run on Arm64 based platforms already.


This is excellent news for those who compile the application themselves, thanks a lot!

thank you, that is helpful information!

i am currently writing some ansible roles to install and maintain seafile. personally i will rather try to fix (or reimplement) the alternative script instead of running the version because i prefer to go through the build process one step at a time.

Are ya’ll still on target to release seafile pro 11 in the next few days?