Seafile drive client 1.0.0 is ready!

There may be other issues we don’t know yet. So we will wait for feedbacks. If no other issues discovered, we will make the option as default.

3 Likes

Thanks for the notification. It is removed now.

Wasn’t v1.0 supposed to work with encrypted libraries ? When will this happen ?

1 Like

Meh :smiley: production ready and there is my issue, unsolved for almost one year.

2 Likes

Do you still have the problem? We don’t received such report from other users so far and the kernel drive is updated to the latest version already.

The encrypted library support is planned to be added after version 1.0. The difficulty it the UI part. There is no way to open a window when a encrypted library is clicked.

Yes. Of course after some updates, there is smaller number of occurs. But copying still sometimes freezes, same as application which opening file. If user have enabled file preview in file explorer, it’s extremely slow down whole OS and only select different file in same folder take few seconds.

To prevent network delay, there still isn’t proxy cache for file block.

I consult it with a lot people. They independently said that it should be more like standard client, just select which library you want to have in "disk S:". And they are right. Just click “sync this library” same way as you do in standard client. You select library/folder name in disk root(this will take of these four confusing folders), and you can write password for encrypted library. Finally after you get SeaDrive stable, you can join SeaDrive and standard client.

you can try this in the meantime

Hi,

installation of 1.0.0 version failed :frowning:

[23B0:2AF8][2018-11-23T17:16:01]i304: Verified existing payload: SeaDrivePrograms at path: C:\ProgramData\Package Cache\{647E11A1-ABEF-49D0-8041-1E9196A86BA7}v1.0.0\seadrive.msi.
[23B0:23A8][2018-11-23T17:16:01]i301: Applying execute package: dokan_clean.exe, action: Install, path: 
 C:\ProgramData\Package Cache\BB22E879FDEEA11BD4929E54A0B97384398EF23F\dokan-clean.exe, arguments: '"C:\ProgramData\Package Cache\BB22E879FDEEA11BD4929E54A0B97384398EF23F\dokan-clean.exe" -x'
[23B0:23A8][2018-11-23T17:16:07]e000: Error 0x80070667: Process returned error: 0x667
[23B0:23A8][2018-11-23T17:16:07]e000: Error 0x80070667: Failed to execute EXE package.
[2090:211C][2018-11-23T17:16:07]e000: Error 0x80070667: Failed to configure per-machine EXE package. 
[2090:211C][2018-11-23T17:16:07]i319: Applied execute package: dokan_clean.exe, result: 0x80070667, restart: None
[2090:211C][2018-11-23T17:16:07]e000: Error 0x80070667: Failed to execute EXE package.
[23B0:23A8][2018-11-23T17:16:07]i351: Removing cached package: dokan_clean.exe, from path:
C:\ProgramData\Package Cache\BB22E879FDEEA11BD4929E54A0B97384398EF23F\

arguments passed to the msi file are incorrect… (on a W10 French version)
reinstalled 0.9.5 without trouble
reinstalled 1.0.0 over 0.9.5 and it works now …

@esamimbias Thanks for reporting this. May I ask:

  • Are you installing SeaDrive client on your computer for the first time, or upgrading from an existing installation?
  • Have you ever manually installed other version of dokany in your system?

btw, where did you see that (except the 0x667 exit code in the log file)?

I see it’ it’s from the installer dialog.

After some testing, it looks good. But we again hit error with bigger num of PDFs.
Going to send log file over PM.

And I got another bug.

If you have SeaDrive alongside Seafile client on windows, and disable explorer extension in client and not in SeaDrive, it disapear from file context menu. When you enable it in client there apear SeaDrive menu. How the hell can Seafile client control SeaDrive context menu?

Seafile and SeaDrive client use the same explorer extension to bypass Windows limitation. From your description, there should be a bug for the extension to detect which menu it should show. Can you try close both clients and restart again?

What error do you get in Windows explorer? The errors in the log indicate that it’s because SeaDrive doesn’t support setting folders to hidden. I cannot see other errors. Are the folders and files copied at last?

Yes, we tried restart SeaDrive multiple times, same as whole machine.

I don’t know what you mean. “Don’t show hidden folders and files” settings? or what?

And this mean what? We just grab multiple files from disk C:/ a move/copy it to some folder in S:/.

Uninstall any old versions of “Dokan” and Seafile Drive, then it should work.

I mean in the virtual drive, it’s not supported to set a folder to “hidden”, which may be used by some applications. But I’m not sure whether this behavior will cause the copy operation to fail.

Is there any way to run on windows 10, with command line?

You can run it in a similar way as for Linux command line. Just replace the seadrive command with its full path on Windows.

Note that the “-f” options is not necessary and unsupported on Windows. So you just run seadrive like:

seadrive -c ~/seadrive.conf -d data-directory [-l logfile] S