Seafile Drive client 2.0 is ready for testing!

We are pleased to announce that the drive client 2.0 is ready for testing.

The main change is that we use a new Windows technology to implement it instead of using a third-party kernel drive. The experience and compatibility with third-party programs are much better. Encrypted libraries are also supported now.

The usage document: https://download.seafile.com/published/seafile-user-manual/drive_client/drive_client_2.0_for_windows_10.md

The beta version can be downloaded here:

6 Likes

Cool. Especially the encrypted lib support. Will test it ASAP. Is this new drive client still closed source ? Are there plan to add encrypted support also on the Linux drive client ?

Regards,
Daniel

This new drive is still closed source. But we will open source the code for Linux. The Linux drive will have encrypted library support too in version 2.0.

4 Likes

Hello,
i tested the new client on my Windwos 10 machine (Version 1909). I deinstall the old seadrive (latest seadrive v1) installation before, install the new one (Version 2.0) and restart the pc.

At first seadrive wasn´t in my autostart. After I start the programm manually, I can´t see any drive in my explorer.
Then I activated the autostart in the configuration of seadrive and restarted the pc. After restart seadrive shows following errors.

seadrive2-error seadrive2-error1

Regards
Termi2

PS. I also reinstall Seadrive, but it shows same problems.

this … is … awesome !!!

On first glance it works like a charm. Only thing is you have to uninstall 1.0 first. 2.0 does not uninstall old versions first.

Hi,

It looks that on Win 10 pro, Seadrive is not completely installed.

I previously desinstal seadrive 1.04 and restarted the computer

It is not in the programm list
It does not start while clicking on seadrive.exe here

Repairing the install does nothing [more

[EDIT]

Well, seadrive is started

image

If is disconnect the account, i get an error

image

Then a timout and a reconnection attemps (SAML) >> OK

Seadrive gets the list of files

And then S drive is displayed

All libraries are synced

But readonly libaries gives an error (never happened on seadrive 1.04)

image

I hope the cache problem did not create any mess on the server

I supose that cleaning the cache from seadrive 1.04 would have been better…

I finally unistalled seadrive 2.0


I had to install seadrive 2.0 twice (once before, once after reboot), i had latest seadrive v1 installed. After starting seadrive 2.0 some librarys (some shared to me, some that i own) are updated without user interaction by the seadrive client. When checking the file history, the modification is empty. Is this desired behaviour? If yes, what’s happening?

First off, this is amazing!! Native Windows integration, support for encrypted libraries, “always keep in sync” feature, and deployment via MSI - and I thought Christmas was 9 months out :wink:

But there are some issues still. My preliminary test results in order of importance:

Top 0: Error message when rebooting

I confirm the problem on my machine (Window 10 1909).

Top 1: Automatic file locking with office files

Automatic file locking works for DOCX, XLSX und PPTX files when opened in Seahub (tested with Onlyoffice).

Automatic file locking also works for XLSX files when opened locally with Excel.

But it does NOT work reliably with DOCX and PPTX files when edited locally (see below). Sometimes it works, sometimes it doesn’t (more often, it doesn’t). At first, I thought it only worked for files not-pinned. But with further tests, this hypothesis turned out to be wrong.

Top 2: Manual file locking for other file types
When non-office files get locked manually in Seahub, any edits done locally are not synced for as long as the file is locked. When the file is unlocked, conflict files are produced. So far, so good.

But: The locally edited files never reach a “sync” status. The status remains „sync pending". A reboot did not change it.

Top 3: CPU load
After I played around with file locking, my computer was sluggish. So I did some checking. This is what I found. There was no download going on.

grafik

Top 4: Cosmetics


Finally, a question: Will you add back a context menu to create upload-/download-links, to see previous versions and lock a file manually?
grafik

3 Likes

Hi @Termi2

I believe this is due to the fact that we haven’t updated the code for auto start. It will try to start the old seadrive client (1.0.x version). The seadrive.exe in 2.0 version doesn’t rely on libcrypto-1_1-x64.dll. The new client should work if you disable auto start.

Hi @Andre

Since we change the method for packaging. We’re somehow unable to auto uninstall the 1.0.x client. We’ll try to fix that in the next version.

I can confirm the issue that it’s not found in the program list. We’ll fix that. But the new client can be started by clicking the icon in your desktop, or enter seadrive in Windows search. You should not start the seadrvie.exe directly. You should run seadrive-gui.exe in the parent folder.

I think you somehow managed to start the old client, instead of the new client?

@92lleo

I also noticed this issue. If you look at Activities in your web interface, you’ll find that the client tried to change the name of the library, but actually no effect. We’ll fix it.

Hi @rdb

I tested with docx and pptx files. It can auto lock the files. Have you checked web interface and refresh the local folder in file explorer? Perhaps the icon just doesn’t change immediately.

We’ll fix it.

We’ll check that. It may be related to the old file explorer extension (not needed now).

Yes it’s in the plan. We’ll add it back in 1-2 versions.

I think i found a bug

I have 2 Seafile Server running (1 Company, 1 Privat). On the second account i added, i can’t select the encrypted libraries. It still shows me the encrypted libraries from the first account.

But so far, it is really good. The first file list download takes ages (2x >700.000 files/1,5tb). But i think i can live with that.

@Jonathan

I thougt the same, but waiting and manual refreshes do not help. I waited for several minutes. No change.

It works great with XLSX files and Excel.

I use MS Office 365 on Windows 10 (1909) 64Bit. Prior to installing SeaDrive 2, I uninstalled SeaDrive 1.0.4. I only use Windows Defender as AV programm.

On a positive note, I have been using SeaDrive 2.0 for two full days now and apart from the reported issues, I can only say good things about the new release!! Great job!

Just came across another problem: SeaDrive’s systray icon is there, the seadrive-gui.exe and seadrive.exe are running, but there is no SeaDrive Icon in Windows Explorer’s navigation bar. Double-clicking on the systray icon does not bring up a new window.


What I did before is uninstall OneDrive. Is OneDrive a requirement for SeaDrive 2.0? Does uninstalling OneDrive affect SeaDrive?

Apologies for the flurry of posts. Just found another issue with file locking that I wanted to share.

I cannot rule out that the problems with file locking are idiosyncratic to my computer. I wonder if other users encounter the same problems.

i played a bit around. I think the file list loading isn’t the best. Switching between accounts takes 10 - 20 minutes on an core i7 with an 2tb NVMe drive.

While its switching, the gui is not responding anymore and Windows-Search service is going insane. The strange part is, that i already excluded the whole seadrive and seadrile_root folder from indexing.

The Encrypted library function is also a bit bugged. I can select multiple Libraries and select “Sync” but when i enter the password it is sometimes syncin only the first library, sometimes nothing, sometimes its crashing.

If i select only one library, enter the password and click OK the Library list gets gray and shows only “No Encrypted Library”, then after a while the GUI crashes.

This are the Log File entries:

[03/22/20 11:27:35] failed to set the password of encrypted library: '[' or '{' expected near end of file

[03/22/20 11:27:35] failed to write to named pipe: 
[03/22/20 11:27:35] failed to send rpc call: No error
[03/22/20 11:27:35] failed to get list of encrypted library, errors: Transport Error.

[03/22/20 11:27:35] failed to get encrypt library list
[03/22/20 11:27:35] Seadrive daemon process crashed with code -1073741819 

or:
[03/22/20 12:23:31] failed to set the password of encrypted library: unable to decode byte 0x80

[03/22/20 12:23:31] failed to write to named pipe: 
[03/22/20 12:23:31] failed to send rpc call: No error
[03/22/20 12:23:31] failed to get list of encrypted library, errors: Transport Error.

[03/22/20 12:23:31] failed to get encrypt library list
[03/22/20 12:23:31] failed to write to named pipe: 
[03/22/20 12:23:31] failed to send rpc call: No error
[03/22/20 12:23:31] failed to get seadrive.events: Transport Error

[03/22/20 12:23:31] failed to write to named pipe: 
[03/22/20 12:23:31] failed to send rpc call: No error
[03/22/20 12:23:31] failed to get sync notification: Transport Error

[03/22/20 12:23:31] failed to write to named pipe: 
[03/22/20 12:23:31] failed to send rpc call: No error
[03/22/20 12:23:31] failed to get global sync status: Transport Error

[03/22/20 12:23:31] failed to write to named pipe: 
[03/22/20 12:23:31] failed to send rpc call: No error
[03/22/20 12:23:31] failed to get sync errors: Transport Error

[03/22/20 12:23:31] Seadrive daemon process crashed with code -1073741819

I’m also curious why it scans my complete user folder? I get tons of errors about this in the log file

Seadrive was not available while searching it in Windows search

I made a mistake, there was no S letter.
And fortunately, there was no sync mess at all :wink:

But retreiving the files was very long.
I’m quite sure we should disconnect from older version (clear cache) before uninstalling it.
Do you confirm that ?

I’ll make some other tests later.