Seafile server pro multi container serves default.png over http

I’ve just installed a new dockerized instance .
No changes to the docker-compose.yml except for passwords , url etc.

Once I login with firefox I get the yellow padlock (connection not secure)

Inspecting the with developers tools shows that default.png is served over port 8000 in plain http

screenshot_2020-06-09_10-04-58

How can I fix this?

Also changing the SERVICE_URL under System Admin -> Settings. from this post Seafile: /media/avatars loading from the wrong URL don’t fixes the issue

I see this as well. Can anyone help here?

Did you delete /tmp/seahub_cache after changing SERVICE_URL?

I do not believe this directory exists in a docker container installation…I do not have a /tmp/seahub_cache directory in my seafile server nor any directory named seahub_cache.

Thanks
Ray