Seafile with nginx and fast-cgi

I have this setting:

Seafile v5.1.4 64-bit
CentOS 7
Nginx 1.6.3

On the Server-Manual you have a conf for Nginx which was not working with my Situation. I did start the Seahub with start-fastcgi.

In the Nginx conf you have this:

location /media { root /home/user/haiwen/seafile-server-latest/seahub; }

  • When I do my Nginx WITHOUT this section, the site what Ngnix shows me is correct
  • When i do my Nginx WITH the section, the site what Ngnix shows is without pics and css and so on

Is this section in Nginx conf really needed?

Other point: can you mention in you docs that if is CentOS 7 used, that you have to turn off SELINUX? Thank you.

Thank you.

CentOS 7.2 in a VPS
Nginx 1.10.1
Seafile 6.0.5

It seems that I have the same phenomenon:

Deleting the path to the media folder enables the webinterface to work.

Is there any impact on this expected?

Could this cause any security issues?

It’s not really logical, is it?

Would be nice to understand what’s going on here.

I thought it would be some sort of permission issue.

Greeting, Chris

Could this be the cause that the WebGUI upload does not work?

I have that problem: