[Solved] "Page unavailable" error when upgading from 6.0.9 to 6.2.5 and 6.3.2

Tried to upgrade to 6.2.5. The scripts to 6.2 errored, but I was able to fix with instructions here:

Now the web interface is broken. As instructed, I changed my Apache config from fcgi:// to and I now get a login screen, but after login I get the error:

Page unavailable
Sorry, but the requested page is unavailable due to a server hiccup.
Our engineers have been notified, so check back later.

I upgraded to 6.3.2 to see if this helped anything, but I get the same error.

Looking in seahub.log:

2018-09-03 16:38:26,396 [ERROR] django.request:135 handle_uncaught_exception Internal Server Error: /api2/repos/
Traceback (most recent call last):
  File "<seafile path>/seafile-server-6.3.2/seahub/thirdpart/django/core/handlers/exception.py", line 41, in inner
    response = get_response(request)
  File "<seafile path>/seafile-server-6.3.2/seahub/thirdpart/django/core/handlers/base.py", line 249, in _legacy_get_response
    response = self._get_response(request)
  File "<seafile path>/seafile-server-6.3.2/seahub/thirdpart/django/core/handlers/base.py", line 187, in _get_response
    response = self.process_exception_by_middleware(e, request)
  File "<seafile path>/seafile-server-6.3.2/seahub/thirdpart/django/core/handlers/base.py", line 185, in _get_response
    response = wrapped_callback(request, *callback_args, **callback_kwargs)
  File "<seafile path>/seafile-server-6.3.2/seahub/thirdpart/django/views/decorators/csrf.py", line 58, in wrapped_view
    return view_func(*args, **kwargs)
  File "<seafile path>/seafile-server-6.3.2/seahub/thirdpart/django/views/generic/base.py", line 68, in view
    return self.dispatch(request, *args, **kwargs)
  File "<seafile path>/seafile-server-6.3.2/seahub/seahub/api2/base.py", line 23, in dispatch
    response = super(APIView, self).dispatch(*a, **kw)
  File "<seafile path>/seafile-server-6.3.2/seahub/thirdpart/rest_framework/views.py", line 466, in dispatch
    response = self.handle_exception(exc)
  File "<seafile path>/seafile-server-6.3.2/seahub/seahub/api2/base.py", line 20, in handle_exception
    return super(APIView, self).handle_exception(exc)
  File "<seafile path>/seafile-server-6.3.2/seahub/thirdpart/rest_framework/views.py", line 463, in dispatch
    response = handler(request, *args, **kwargs)
  File "<seafile path>/seafile-server-6.3.2/seahub/seahub/api2/views.py", line 729, in get
    group_repos = seafile_api.get_group_repos_by_user(email)
  File "<seafile path>/seafile-server-6.3.2/seafile/lib64/python2.7/site-packages/seaserv/api.py", line 456, in get_group_repos_by_user
    return seafserv_threaded_rpc.get_group_repos_by_user(user)
AttributeError: 'SeafServerThreadedRpcClient' object has no attribute 'get_group_repos_by_user'

I’ve tried searching for solutions to the

AttributeError: ‘SeafServerThreadedRpcClient’ object has no attribute ‘get_group_repos_by_user’

error, but have not found anything useful.

What should me next step be to resolve this issue?


Well this is embarrassing! I was looking back at one of my old posts from a year ago, and it turns out I was having the same issue (just a different error message):

I looked in /usr/lib/python2.7/dist-packages and removed (renamed/disabled) any ccnet, seafile, or seaserv directories. After restarting seafile, the web interface is working again!

I’m not sure why this keeps happening to me, but hopefully this post will help someone else with the same issue.