Where's the internal file link button?

Hello everybody

since the latest client version update (7.0.1 CE) we miss the button in the right mouse-click menue in windows explorer to create internal links to share files.
There’s only one button left, which creates a weblink. It opens a browser window with our seafile folder instead of opening the file. And due we use library passwords, its basically not usable anymore.

Any ideas? Thank you very much for your help

Hi Andi,
please update to the lastest version.
For more info, please see here: Seafile server community edition 7.0.4 is ready! The forum post includes a discussion about the internal link feature.

Thank you very much, due I assuem it’s a client issue isn’t it? The client is on 7.0.1 (won’t update on 7.0.2). Correction: Manual update worked just fine

Anyhow, We’ll give it a try to update the server version.

The mentioned discussion is about the internal links in the Seahub webinterface.

I can create internal files and folder links with Seafile Client 7.0.2 (Windows) with Seafile 7.0.4 CE in the internal browser as well as in Windows Explorer.

But that’s not what I meant. I’m looking for internal links in the right-mouse-button-menue using Windows file explorer and not browsing the webinterface. Before updating on 7.0.1 this option was available but now disappeared. Update to 7.0.2 didn’t solved the issue.

I do only see sharing-links with an IP leading to the file. But this link will open the folder in browser instead of opening the file directly. Due our bliblio is password protected the recipients of the links will get only a “Repo is encrypted. Please provide password to view it.” message.

I would be very happy to have a solution. With not beeing able to share links to files, for me one of the main advantages is missing. Looking forward to your advice :slight_smile:

I try to recapitulate.
You are missing this function:


You had this function prior to upgrading your Sync client to version 7. After the upgrade, no more. Neither with Seafile Sync Client 7.0.1 nor 7.0.2.
Is this correct?

Well, here is what I can test:
The screenshot above is from my Windows 10 machine running Seafile Sync Client v7.0.1. I connected to a Seafile Server PE 7.0.8 and CE 7.0.4. I also tried encryted and unencrypted libraries. The result was always the same: I could generate an internal link. Hence, it seems a specific problem to your computer.

Questions for you:

  • Have your reinstalled the Sync client?
  • Is the problem prevalent on all your machines or just some?

Hi

Thank you very much! And yes, this matches exactly our issue.

  • Yes we reinstalled Sync Client
  • Its prevalent to all our machines

That’s what I meant with my second sentence “..internal browser as well as in Windows Explorer…”. So the feature you where searching for is working for me (on Windows 7).

ok, thank you. I understand. Nevertheless I still can’t find the root cause of this issue.

Hi rdb, do you have any ideas to solve this issue? Nothing helped so far. Thank you in advance

I have no good idea anymore. Sorry for that. This is a long shot: Maybe there is something in your AV software or group policies that prevents the context menu item from popping up. I think it is worth a try if internal links are important to you.

Please set up a fresh Win 10 instance in a virtual machine. It is very easy using the HyperV shipped with every Windows 10 Pro. You just have to enable it in the Windows-Features settings - see screenshot.
grafik

To test for any conflicts with AV or whatever sort of security software, don’t install anything else but Windows Defender. In the same vein, do not add the VM to your domain. Just install the client and try again. If this doesn’t work, I am literally out of ideas.

Have you checked if the Seafile shell extension is present in the Windows Registry?

Hi everybody, we’ll give it a try and come back with news, when we found the root cause.

So far, many thanks to @rdb and @Martin !!!

Hello @rdb @Martin
We didn’t found the root cause. Anyhow we rolled back our clientes through several versions and ended at 6.1.0. With this client version the internal links do work again. Not so good, but at least it works again. We’ll keep searching.

Thank you again!