Two factor auth is enabled, no access to webdav

Hello, I am using seafile server 8.0.2 with https behind nginx. 2FA is enabled. I tried to setup webdav according to the instructions in the seafile manual. However, I am unable to connect to webdav. The error message on a linux client is: Could not authenticate to server: rejected Basic challenge

In the seafdav.log file on the server, a message is: “Two factor auth is enabled, no access to webdav.” <-- Does this message mean that there is no possibility to access webdav with 2FA enabled? Is there some way around this, other than disabling 2FA?

See Disable webdav for users that have 2fa enabled

Thanks @92lleo. It seems, based on the thread you referenced, that with 8.0.2, users can either use webdav and forego 2FA, or they can enable 2FA and forego webdav. It’s not possible to use both using e.g. an application specific password for webdav or some other scheme. Now I regret updating :frowning:

While it’d be great for this to be fixed, I think this thread can be closed since the current state of affairs does not support 2FA as well as webdav at the same time. Hopefully, the documentation/changelog is updated to reflect this.