Seafile version 6.1.1 is ready!

We are glad to announce that Seafile version 6.1.1 is ready! This is a stable is release with the following improvements:

  • Disable thumbnail for video files in default. Because this feature needs additional packages that can’t be easily installed in platforms like Raspberry Pi.
  • Enable fixing the email for share link to be fixed in certain language (option SHARE_LINK_EMAIL_LANGUAGE in So admin can force the language for a email of a share link to be always in English, regardless of what language the sender is using.
  • The language of the interface of CollaboraOffice/OnlyOffice will be determined by the language of the current user.
  • Display the correct image thumbnails in favorites instead of the generic one
  • Enable set favicon and logo via admin panel
  • Admin can add libraries in admin panel

Please merge the following ASAP, important info / fixes regarding 6.1:

This one would also be nice, so we can continue to work on it.
I cloned a branch instead of the master, that’s why info from this one is double, please just merge both and it should be fine.

When trying to upload a favicon.ico with 32x32 I receive an

Also tried .png, smaller and bigger files. Same problem.

New feature “Enable set favicon and logo via admin panel” looks like great:

Changing to default seafile icon is empty:

Another icon works >32x32, only seafile favicon not:

1 Like

try another size, for me it is working, only the original one (which is 32x32) doesn’t work like expected. Tested on ARM (Raspberry Pi) (fresh compilation).

Another point is to create another button with “restore default seafile icon” or similar. The path for the favicon and seafile logo are in \seafile-server-6.1.1\seahub\media\img

Edit: Interesting is the fact that I don’t get the “Internal Error” BUT it is the case. Which browser did you use?

1 Like



I just replaced it via cli just like in the past for now.

When changing the favicon it should also give a note that this requires a restart of seahub to work properly.

For me works the change of the icon (not the seafile original one) out the box. I have only to presh F5, and the refresh do the magic.

So what seems to be the error? I assume you are using nginx on the pi?

yes, nginx. I don’t know.

I’ve had the following line in my nginx config for quiet a while, but removing it didn’t help.
I don’t remeber why I’ve had to put it there.

location /favicon.ico {
      alias /usr/share/nginx/html/favicon.ico;

Do you use Seafile PRO ?

No PRO. The issue relies IMHO not in NGINX, or config block in NGINX since another icons that are not the original one works well. When I change to the original one, I can see for short moment that it is placed there but suddenly disappears.

OK, doing tests I got it: Seahub is not taking icons that are 32x32 size. The size should be bigger. I made tests with 128x128 and 256x256. They work all of them fine, only not 32x32 in ico format file. Refreshing with F5 works well.

Edit: attached two image files

Still does not work here.
Debian 8.8 AMD64

Favicon doesn’t work for me - I tried misc. sizes. Logo works fine.
Running on x86_64 Debian, 8.8 Stable

i also had issues but i do this manually instead of gui

i added this line to

FAVICON_PATH = ‘custom/favicon.png’

copied by ico file to /home/haiwen(or whatever)/seahub-data/custom

make sure its atleast 32x32 pixels. otherwise it doesnt work

This way it works also for us, but if the option is provided in the gui it should work. :slight_smile:

@xiez @daniel.pan
The Logo size actually needs to be 256x55 and not 256x64 to be displayed correctly in the top bar. It’s warped otherwise.
Why do you ask for this size in the gui?

If you have problem when customizing favicon through the GUI, try update the Python Pillow module by sudo pip install --upgrade Pillow.

If still not working properly after the update,please upload your Icon file here to help us to reproduce this problem.

Why wasn’t this mentioned in the manual?

Do you test your Software on all supported distros?
Often we see only instructions for Ubuntu and CentOS, but what about Debian and the RPi OS?

I think that we need to mention stuff like that in the upgrade manual. Please approve the upgrade notes files, so we can work further on them and add required information. Ty

Error on Debian Jessie

pip install --upgrade Pillow

The headers or library files could not be found for jpeg,
a required dependency when compiling Pillow from source.

Command /usr/bin/python -c "import setuptools, tokenize;__file__='/tmp/pip-build-thwks0/Pillow/';
exec(compile(getattr(tokenize, 'open', open)(__file__).read().replace('\r\n', '\n'), __file__, 'exec'))" install 
--record /tmp/pip-Lv97v9-record/install-record.txt --single-version-externally-managed --compile failed with 
error code 1 in /tmp/pip-build-thwks0/Pillow
Storing debug log for failure in /root/.pip/pip.log

Solution for Debian Jessie

apt-get build-dep python-imaging
pip install --upgrade Pillow

version Pillow 4.1.1
platform linux2 2.7.9 (default, Jun 29 2016, 13:08:31)
[GCC 4.9.2]
— JPEG support available
*** OPENJPEG (JPEG2000) support not available
— ZLIB (PNG/ZIP) support available
*** LIBIMAGEQUANT support not available
— LIBTIFF support available
— FREETYPE2 support available
— LITTLECMS2 support available
— WEBP support available
— WEBPMUX support available


- Ubuntu 16.04.2 LTS

  • check the Pillow version:

pip list --format=columns | grep -i pillow
Pillow 3.1.2

  • upgrade Pillow until last version:

pip install --upgrade Pillow

The headers or library files could not be found for jpeg,
  a required dependency when compiling Pillow from source.

  Please see the install instructions at:

I had the same compiling error that commented by @DerDanilo
On Stackoverflow there is the explanation behind the unmet pillow dependencies, like jpeg

  • Upgrade Pillow unmet dependencies, here the jpeg libraries:

apt-get install libjpeg-dev (*)

  • Upgrade Pillow:

pip install --upgrade Pillow

  • Check that the upgraded Pillow version is 4.1.1:

pip list --format=columns | grep -i pillow
Pillow 4.1.1

(*) If you install like apt-get build-dep python-imaging it will install many packages that are not necessary. Totally 165 MB occupied in disk:

apt-get build-dep python-imaging
Paketlisten werden gelesen... Fertig
Als Quellpaket wird »pillow« statt »python-imaging« gewählt.
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
Die folgenden NEUEN Pakete werden installiert:
  blt libfontconfig1-dev libfreetype6-dev libice-dev libice6 libjbig-dev libjpeg-dev libjpeg-turbo8-dev
  libjpeg8-dev liblcms2-dev liblzma-dev libpng12-dev libpthread-stubs0-dev libpython-all-dbg libpython-dbg
  libpython2.7-dbg libpython3-all-dbg libpython3-all-dev libpython3-dbg libpython3-dev libpython3.5-dbg
  libpython3.5-dev libsm-dev libsm6 libtcl8.6 libtiff5-dev libtiffxx5 libtk8.6 libwebp-dev libwebpdemux1
  libx11-dev libxau-dev libxcb1-dev libxdmcp-dev libxext-dev libxft-dev libxft2 libxrender-dev libxss-dev
  libxss1 libxt-dev libxt6 python-all-dbg python-dbg python-nose python-tk python-tk-dbg python2.7-dbg
  python3-all python3-all-dbg python3-all-dev python3-dbg python3-dev python3-nose python3-setuptools
  python3-tk python3-tk-dbg python3.5-dbg python3.5-dev tcl tcl-dev tcl8.6 tcl8.6-dev tk tk-dev tk8.6
  tk8.6-blt2.5 tk8.6-dev x11-common x11proto-core-dev x11proto-input-dev x11proto-kb-dev x11proto-render-dev
  x11proto-scrnsaver-dev x11proto-xext-dev xorg-sgml-doctools xtrans-dev
0 aktualisiert, 77 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
Es müssen 79,9 MB an Archiven heruntergeladen werden.
Nach dieser Operation werden 165 MB Plattenplatz zusätzlich benutzt.

but if you only install like apt-get install libjpeg-dev, you only will need less than 1 MB place on disk:

apt-get install libjpeg-dev
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
The following additional packages will be installed:
  libjpeg-turbo8-dev libjpeg8-dev
Die folgenden NEUEN Pakete werden installiert:
  libjpeg-dev libjpeg-turbo8-dev libjpeg8-dev
0 aktualisiert, 3 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
Es müssen 225 kB an Archiven heruntergeladen werden.
Nach dieser Operation werden 825 kB Plattenplatz zusätzlich benutzt.
  • My recommendation:

Try to install first only libjpeg-dev, if this is not enough, then install like apt-get build-dep python-imaging

Edit: After Pillow upgrade to 4.1.1 the NEW “change favicon functionality” works properly.

Thanks @lian. Like @DerDanilo suggested, the documentation should be improved or seafile integration with other distros should be improved, to avoid such glitches.


These things need to go to the manual and should be known before a new version is released as stable. This is not hard to accomplish. Someone just has to write down every change that has be done with every version.

That is the reason I started writing the Upgrade notes but they have not been merged yet. :-/
@daniel.pan Please merge, so we can continue adding important information there for whole userbase.

Hi, that sounds great, I saw that for PRO edition the download is not ready yet… when is will be available?
Thank you

1 Like